aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorParthiban Nallathambi <parthitce@gmail.com>2019-05-01 14:52:50 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-03 10:04:45 -0700
commitceda4b3ac56d7a3ddc27b0d5dda3ba27c9c6f17a (patch)
treefdf1a58f144737ecd7458f097796c9e69c959798 /meta-python/recipes-devtools/python
parentc5c6e9b545d1f108975498cb4b0d34b40a254d91 (diff)
downloadmeta-openembedded-ceda4b3ac56d7a3ddc27b0d5dda3ba27c9c6f17a.tar.gz
python3-websocket-client: add version 0.56.0
DEPENS on python-six Signed-off-by: Parthiban Nallathambi <parthitce@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-websocket-client.inc18
-rw-r--r--meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb2
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-websocket-client.inc b/meta-python/recipes-devtools/python/python-websocket-client.inc
new file mode 100644
index 0000000000..c4214b2fde
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-websocket-client.inc
@@ -0,0 +1,18 @@
+SUMMARY = "websocket client for python"
+DESCRIPTION = "\
+websocket-client module is WebSocket client for python. \
+This provide the low level APIs for WebSocket. All APIs \
+are the synchronous functions."
+HOMEPAGE = "https://github.com/websocket-client/websocket-client"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c4c4a98fbc4836b81c8c64d6ecb01fc1"
+
+SRC_URI[md5sum] = "89484bd5dac71123ae6a09b2f90fe62c"
+SRC_URI[sha256sum] = "1fd5520878b68b84b5748bb30e592b10d0a91529d5383f74f4964e72b297fd3a"
+
+PYPI_PACKAGE = "websocket_client"
+inherit pypi
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-six \
+"
diff --git a/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
new file mode 100644
index 0000000000..9b6696ead1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-websocket-client.inc