aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-06-08 16:38:00 +0800
committerKhem Raj <raj.khem@gmail.com>2021-06-09 08:45:24 -0700
commitcf84284bb07a2e3d80e8aa6a7a7a33812d8636d8 (patch)
treeabc7fc57b0bb180e12f2ba23afebc9524ba12b18 /meta-python/recipes-devtools/python
parent31df5f346ea6bff82dcc414012108e26579b2a7d (diff)
downloadmeta-openembedded-cf84284bb07a2e3d80e8aa6a7a7a33812d8636d8.tar.gz
python3-m2crypto: fix word size for qemuppc64 little endian
It fails to compile python3-m2crypto for qemuppc64 little endian: | /path/to/tmp-glibc/work/ppc64p9le-wrs-linux/python3-m2crypto/0.37.1-r0/ recipe-sysroot/usr/include/openssl/opensslconf.h:23: | Error: Unable to find 'openssl/opensslconf-32.h' It defines '__powerpc64le__' but expects '__powerpc64__'. Define the right macro for qemuppc64le. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
index e1f92928c6..2284a43a3b 100644
--- a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
+++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
@@ -39,6 +39,7 @@ SWIG_FEATURES ?= "-D__${HOST_ARCH}__ ${@['-D__ILP32__','-D__LP64__'][d.getVar('S
SWIG_FEATURES_append_riscv64 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
SWIG_FEATURES_append_riscv32 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
SWIG_FEATURES_append_mipsarch = " -D_MIPS_SZPTR=${SITEINFO_BITS}"
+SWIG_FEATURES_append_powerpc64le = " -D__powerpc64__"
export SWIG_FEATURES
BBCLASSEXTEND = "native"