aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-08-25 10:33:35 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-26 09:57:25 -0700
commitea86c829bbe6836da1210b9b8e4ab1ded5381e8e (patch)
treecdab08e1b7474f3a24f179567715eca61ec54468 /meta-python/recipes-devtools/python
parent961755a7bd17f7347f7dd0f2de3d2400a9c36f09 (diff)
downloadmeta-openembedded-ea86c829bbe6836da1210b9b8e4ab1ded5381e8e.tar.gz
python3-eventlet: add 0.30.2 to meta-python
python3-gunicorn in meta-python relies on python3-eventlet for its ptests, so add a version of the eventlet recipe to the layer and update to the latest version. This recipe file is based on the one from the meta-openstack layer, but the .inc and .bb files have been combined. Also add python3-dnspython to RDEPENDS so that "import eventlet" works. Note that there is a newer version of eventlet, but anything 0.30.3 and newer is incompatible with the current version of gunicorn. eventlet will get another update as soon as there is a new release of gunicorn handling the API change. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-eventlet_0.30.2.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eventlet_0.30.2.bb b/meta-python/recipes-devtools/python/python3-eventlet_0.30.2.bb
new file mode 100644
index 0000000000..80869a2597
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eventlet_0.30.2.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Highly concurrent networking library"
+HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
+
+SRC_URI[md5sum] = "ebf5794e3f7a9f1778fb4f2a58eb7614"
+SRC_URI[sha256sum] = "1811b122d9a45eb5bafba092d36911bca825f835cb648a862bbf984030acff9d"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "${PYTHON_PN}-dnspython"