aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2019-04-16 15:42:24 +0800
committerKhem Raj <raj.khem@gmail.com>2019-04-16 21:07:25 -0700
commit13223cc7007981c5169e9a54402600de177ea131 (patch)
tree76811af3bd604839892e4a9bd4d73103c9679c7d /meta-python/recipes-devtools
parent5ed7b732e1d378d59fa033f558f53b28bd4aef16 (diff)
downloadmeta-openembedded-13223cc7007981c5169e9a54402600de177ea131.tar.gz
python-pycodestyle: Fix conflict error with python3-pycodestyle during do_rootfs
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb b/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb
index 7c736e76f8..ec6c12f2f1 100644
--- a/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb
@@ -2,3 +2,9 @@ inherit setuptools
require python-pycodestyle.inc
RDEPENDS_${PN} += "${PYTHON_PN}-lang"
+
+do_install_append () {
+ if [ -f ${D}${bindir}/pycodestyle ]; then
+ mv ${D}${bindir}/pycodestyle ${D}${bindir}/pycodestyle-2
+ fi
+}