aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-11-30 12:40:26 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:15 +0100
commit336692f24b5ac6c39b65ff3cb971d7bd353ea4e5 (patch)
treed57164cd29b993eccac22e23924cdb4e60c13fb7 /meta-python/recipes-devtools
parent9d40291916136ed3c4480102708e75d81cc77ef1 (diff)
downloadmeta-openembedded-336692f24b5ac6c39b65ff3cb971d7bd353ea4e5.tar.gz
python-psutil: update to version 5.0.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-psutil.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_5.0.0.bb (renamed from meta-python/recipes-devtools/python/python-psutil_4.2.0.bb)4
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb)4
3 files changed, 8 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-psutil.inc b/meta-python/recipes-devtools/python/python-psutil.inc
index 33573fca9b..13f3695da4 100644
--- a/meta-python/recipes-devtools/python/python-psutil.inc
+++ b/meta-python/recipes-devtools/python/python-psutil.inc
@@ -2,9 +2,13 @@ SUMMARY = "A cross-platform process and system utilities module for Python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
-SRC_URI[md5sum] = "713f259f917a0c26acfbb7e6ae632ef7"
-SRC_URI[sha256sum] = "544f013a0aea7199e07e3efe5627f5d4165179a04c66050b234cc3be2eca1ace"
+SRC_URI[md5sum] = "362a03686ce36940d22a548ecb47d7e0"
+SRC_URI[sha256sum] = "5411e22c63168220f4b8cc42fd05ea96f5b5e65e08b93b675ca50653aea482f8"
+
+PYPI_PACKAGE_EXT = "zip"
RDEPENDS_${PN} += " \
- python-subprocess \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
"
diff --git a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python-psutil_5.0.0.bb
index d718011e4b..bf402aa476 100644
--- a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-psutil_5.0.0.bb
@@ -1,6 +1,2 @@
inherit pypi setuptools
require python-psutil.inc
-
-RDEPENDS_${PN} += " \
- python-subprocess \
-"
diff --git a/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python3-psutil_5.0.0.bb
index d95332cdc1..c1969ea657 100644
--- a/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.0.0.bb
@@ -1,6 +1,4 @@
inherit pypi setuptools3
require python-psutil.inc
-RDEPENDS_${PN} += " \
- python3-subprocess \
-"
+RDEPENDS_${PN} += "${PYTHON_PN}-netclient"