aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-30 12:31:29 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-11 11:50:56 -0800
commit3e55d229f98894f82013562bca897f2aca3c0c1f (patch)
tree3cc87dc818b77c51d7084bc47812a61f1da149c4 /meta-python/recipes-devtools
parentea5769403a26a813f4300c9d34824baf215ac9c3 (diff)
downloadmeta-openembedded-3e55d229f98894f82013562bca897f2aca3c0c1f.tar.gz
python: remove python3 DEPENDS on python3-misc due to missing _pydecimal.py
Several packages required numbers, but the _pydecimal.py file was incorrectly placed in the misc package. The underlying issue has been resolved upstream, so remove the RDEPENDS here http://lists.openembedded.org/pipermail/openembedded-core/2018-January/146808.html Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-babel_2.5.3.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-django_1.11.9.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-jinja2_2.10.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.23.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.13.2.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb5
9 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python3-babel_2.5.3.bb b/meta-python/recipes-devtools/python/python3-babel_2.5.3.bb
index 05084ac2e5..0715d59f42 100644
--- a/meta-python/recipes-devtools/python/python3-babel_2.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-babel_2.5.3.bb
@@ -1,5 +1,2 @@
inherit setuptools3
require python-babel.inc
-
-# Requires _pydecimal.py which is in misc
-RDEPENDS_${PN} += "${PYTHON_PN}-misc"
diff --git a/meta-python/recipes-devtools/python/python3-django_1.11.9.bb b/meta-python/recipes-devtools/python/python3-django_1.11.9.bb
index ef77603a62..e1e38c3225 100644
--- a/meta-python/recipes-devtools/python/python3-django_1.11.9.bb
+++ b/meta-python/recipes-devtools/python/python3-django_1.11.9.bb
@@ -1,7 +1,2 @@
require python-django.inc
inherit setuptools3
-
-# Requires _pydecimal which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
index 091eb368a5..ce4dfdc74a 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
@@ -1,7 +1,2 @@
inherit setuptools3
require python-dnspython.inc
-
-# Requires _pydecimal.py which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-jinja2_2.10.bb b/meta-python/recipes-devtools/python/python3-jinja2_2.10.bb
index 8375f8cf4e..61156b630b 100644
--- a/meta-python/recipes-devtools/python/python3-jinja2_2.10.bb
+++ b/meta-python/recipes-devtools/python/python3-jinja2_2.10.bb
@@ -1,7 +1,2 @@
inherit pypi setuptools3
require python-jinja2.inc
-
-# Requires _pydecimal which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
index 415ca9f2e8..5164b186bf 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
@@ -1,7 +1,2 @@
inherit pypi setuptools3
require python-pymongo.inc
-
-# Requires _pydecimal which is in misc
-RDEPENDS_${PYTHON_PN}-bson += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.23.bb b/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
index bc8bfff862..1e04def7b7 100644
--- a/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
@@ -1,7 +1,2 @@
inherit setuptools3
require python-serpent.inc
-
-# Requires _pydecimal which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.13.2.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.13.2.bb
index d44bc1526d..38f406c5de 100644
--- a/meta-python/recipes-devtools/python/python3-simplejson_3.13.2.bb
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.13.2.bb
@@ -1,7 +1,2 @@
inherit setuptools3
require python-simplejson.inc
-
-# Requires _pydecimal which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
index eaa0090960..86cf9eddeb 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
@@ -1,5 +1,2 @@
inherit setuptools3
require python-sqlalchemy.inc
-
-# Requires _pydecimal.py which is in misc
-RDEPENDS_${PN} += "${PYTHON_PN}-misc"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index 8ad1c17478..5d8af303c7 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -1,7 +1,2 @@
inherit pypi setuptools3
require python-whoosh.inc
-
-# Requires _pydecimal.py which is in misc
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-misc \
-"