aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-26 21:46:56 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-26 21:52:26 -0800
commit5c455804aede17e0ea0cbb7ab55f8580f912e664 (patch)
tree67d97f9cf071f4639c9cbd1be1a20cf1055fd61e /meta-python/recipes-devtools
parentda03785ff19c2db4210318759a011c6919692876 (diff)
downloadmeta-openembedded-5c455804aede17e0ea0cbb7ab55f8580f912e664.tar.gz
python3-pybind11: Upgrade to 2.10.3
It gets pkgconfig support which is required by some dependent packages like rwmem Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb (renamed from meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb)18
1 files changed, 7 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
index 66aefac3d6..bb604982d0 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
@@ -5,16 +5,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
DEPENDS = "boost"
-SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
- file://0001-Do-not-strip-binaries.patch \
-"
+SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
-SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
+SRCREV = "0bd8896a4010f2d91b2340570c24fa08606ec406"
S = "${WORKDIR}/git"
-BBCLASSEXTEND = "native"
-
EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
inherit cmake setuptools3 python3native
@@ -23,17 +19,17 @@ PIP_INSTALL_DIST_PATH = "${S}/dist"
PIP_INSTALL_PACKAGE = "pybind11"
do_configure() {
- cmake_do_configure
+ cmake_do_configure
}
do_compile() {
- setuptools3_do_compile
- cmake_do_compile
+ setuptools3_do_compile
+ cmake_do_compile
}
do_install() {
- setuptools3_do_install
- cmake_do_install
+ setuptools3_do_install
+ cmake_do_install
}
BBCLASSEXTEND = "native nativesdk"