aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-08-23 14:52:24 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-25 08:15:33 -0700
commit717dbbe5845291c666020a3d92343409ea41d275 (patch)
treebe7e943ee26701d38bd05cd65c4a56fe4a8145eb /meta-python/recipes-devtools
parent39b4558bf07d8b8dbb77a2f8731b0e2f8a86b9df (diff)
downloadmeta-openembedded-717dbbe5845291c666020a3d92343409ea41d275.tar.gz
python3-pyzmq: upgrade 22.1.0 -> 22.2.1
22.2.1 Fix bundling of wepoll on Windows. 22.2.0 New features: IPC support on Windows: where available (64bit Windows wheels and bundled libzmq when compiling from source, via wepoll), IPC should work on appropriate Windows versions. Nicer reprs of contexts and sockets Memory allocated by recv(copy=False) is no longer read-only asyncio: Always reference current loop instead of attaching to the current loop at instantiation time. This fixes e.g. contexts and/or sockets instantiated prior to a call to asyncio.run. ssh: $PYZMQ_PARAMIKO_HOST_KEY_POLICY can be used to set the missing host key policy, e.g. AutoAdd. Fixes: Fix memory corruption in gevent integration Fix memoryview(zmq.Frame) with cffi backend Fix threadsafety issue when closing sockets Changes: pypy Windows wheels are 64b-only, following an update in cibuildwheel 2.0 deprecate zmq.utils.jsonapi and remove support for non-stdlib json implementations in send/recv_json. Custom serialization methods should be used instead. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb (renamed from meta-python/recipes-devtools/python/python3-pyzmq_22.1.0.bb)7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_22.1.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb
index 9e418f04b5..f58074a9a9 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_22.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb
@@ -8,11 +8,14 @@ DEPENDS = "zeromq"
FILESEXTRAPATHS:prepend := "${THISDIR}/python-pyzmq:"
SRC_URI += "file://club-rpath-out.patch"
-SRC_URI[sha256sum] = "7040d6dd85ea65703904d023d7f57fab793d7ffee9ba9e14f3b897f34ff2415d"
+SRC_URI[sha256sum] = "6d18c76676771fd891ca8e0e68da0bbfb88e30129835c0ade748016adb3b6242"
inherit pypi pkgconfig setuptools3
-RDEPENDS:${PN} += "${PYTHON_PN}-multiprocessing"
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-json \
+"
FILES:${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/zmq/backend/cython/.debug"