aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-09 13:35:34 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-13 22:28:31 -0700
commit78025edfb5ccacb74d284c4405eb595bc834a9fa (patch)
treebce13e967d019984053862d5dd676ba1a8228e67 /meta-python/recipes-devtools
parent7c23a0ea1a7d49250a94e52feed96784659fe434 (diff)
downloadmeta-openembedded-78025edfb5ccacb74d284c4405eb595bc834a9fa.tar.gz
python3-markdown: Upgrade 3.2.2 -> 3.3
Upgrade to release 3.3: - The prefix language- is now prepended to all language classes by default on code blocks. - Attribute Lists are more strict. - All Pygments' options are now available for syntax highlighting. - Fenced Code Blocks now work with Attribute Lists when syntax highlighting is disabled. Any random HTML attribute can be defined and set on the <code> tag of fenced code blocks when the attr_list extension is enabled. - The HTML parser has been completely replaced. The new HTML parser is built on Python's html.parser.HTMLParser, which alleviates various bugs and simplify maintenance of the code. - The Markdown in HTML extension has been rebuilt on the new HTML Parser, which drastically simplifies it. Note that raw HTML elements with a markdown attribute defined are now converted to ElementTree Elements and are rendered by the serializer. Various bugs have been fixed. - Link reference parsing, abbreviation reference parsing and footnote reference parsing has all been moved from preprocessors to blockprocessors, which allows them to be nested within other block level elements. Specifically, this change was necessary to maintain the current behavior in the rebuilt Markdown in HTML extension. A few random edge-case bugs (see the included tests) were resolved in the process. - An alternate function markdown.extensions.headerid.slugify_unicode has been included with the Table of Contents extension which supports Unicode characters in table of contents slugs. The old markdown.extensions.headerid.slugify method which removes non-ASCII characters remains the default. Import and pass markdown.extensions.headerid.slugify_unicode to the slugify configuration option to use the new behavior. - Support was added for Python 3.9 and dropped for Python 3.5. - Document how to pass configuration options to Extra. - Fix HR which follows strong em. - Support short reference image links. - Avoid a RecursionError from deeply nested blockquotes. - Fix issues with complex emphasis. - Fix unescaping of HTML characters <> in CodeHilite. - Fix complex scenarios involving lists and admonitions. - Fix complex scenarios with nested ordered and unordered lists in a definition list. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-markdown_3.3.bb (renamed from meta-python/recipes-devtools/python/python3-markdown_3.2.2.bb)5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markdown_3.2.2.bb b/meta-python/recipes-devtools/python/python3-markdown_3.3.bb
index ce5dde63ea..db8311be5d 100644
--- a/meta-python/recipes-devtools/python/python3-markdown_3.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-markdown_3.3.bb
@@ -5,9 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=745aaad0c69c60039e638bff9ffc59ed"
inherit pypi setuptools3
PYPI_PACKAGE = "Markdown"
-PYPI_SRC_URI = "https://files.pythonhosted.org/packages/44/30/cb4555416609a8f75525e34cbacfc721aa5b0044809968b2cf553fd879c7/Markdown-${PV}.tar.gz"
-SRC_URI[md5sum] = "6e8daf1e566bf3572c137ada399fe40b"
-SRC_URI[sha256sum] = "1fafe3f1ecabfb514a5285fca634a53c1b32a81cb0feb154264d55bf2ff22c17"
+SRC_URI[md5sum] = "76eb34a058bb8b637ccadc4ce384bae4"
+SRC_URI[sha256sum] = "4f4172a4e989b97f96860fa434b89895069c576e2b537c4b4eed265266a7affc"
BBCLASSEXTEND = "native"