aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-11-22 18:46:39 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:29:55 +0100
commitac2abd467ec0e88e0c3663a55d38d9bfcbfe4618 (patch)
treec0ac4948ede5e953a4b42eb4e379f5faed43a847 /meta-python/recipes-devtools
parente9053535db4b6f4c9a757a584b1a59555cff4dbb (diff)
downloadmeta-openembedded-ac2abd467ec0e88e0c3663a55d38d9bfcbfe4618.tar.gz
python-pycparser: update to version 2.17
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser_2.17.bb (renamed from meta-python/recipes-devtools/python/python-pycparser_2.14.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pycparser_2.14.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycparser_2.17.bb6
4 files changed, 13 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycparser.inc b/meta-python/recipes-devtools/python/python-pycparser.inc
index bf3b757988..fe8c34d755 100644
--- a/meta-python/recipes-devtools/python/python-pycparser.inc
+++ b/meta-python/recipes-devtools/python/python-pycparser.inc
@@ -1,8 +1,12 @@
SUMMARY = "Parser of the C language, written in pure Python"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8fb364772b1441821d391591f340c35a"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d0cfca7bbc0610f849707d9e4fd82eac"
-SRC_URI[md5sum] = "a2bc8d28c923b4fe2b2c3b4b51a4f935"
-SRC_URI[sha256sum] = "7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73"
+SRC_URI[md5sum] = "ca98dcb50bc1276f230118f6af5a40c7"
+SRC_URI[sha256sum] = "0aac31e917c24cb3357f5a4d5566f2cc91a19ca41862f6c3c22dc60a629673b6"
BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-subprocess \
+ "
diff --git a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python-pycparser_2.17.bb
index adbc1a8f46..adbc1a8f46 100644
--- a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb
+++ b/meta-python/recipes-devtools/python/python-pycparser_2.17.bb
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb
deleted file mode 100644
index b30db54c51..0000000000
--- a/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-pycparser.inc
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.17.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.17.bb
new file mode 100644
index 0000000000..7cc024ea09
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycparser_2.17.bb
@@ -0,0 +1,6 @@
+inherit pypi setuptools3
+require python-pycparser.inc
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-netclient \
+ "