aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-11-22 17:37:40 +0000
committerKhem Raj <raj.khem@gmail.com>2018-11-26 09:38:14 -0800
commitbbbe9a08be6d4c2a003c3f45ef450bc0623f5c7d (patch)
tree620cdb6c74d171b2f41773dc4c910dd991071406 /meta-python/recipes-devtools
parent5ce9fda7fc3418046ea2abaabed3e9a4272d67e3 (diff)
downloadmeta-openembedded-bbbe9a08be6d4c2a003c3f45ef450bc0623f5c7d.tar.gz
python3-bandit: upgrade to 1.5.1
Update dependencies, and cheat by adding python3-modules to RDEPENDS for now. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.5.1.bb14
2 files changed, 14 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb b/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb
deleted file mode 100644
index 84f47614e0..0000000000
--- a/meta-python/recipes-devtools/python/python3-bandit_1.4.0.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "Security oriented static analyser for python code."
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
-
-SRC_URI[md5sum] = "f74155cb9921be857693b32d2531e857"
-SRC_URI[sha256sum] = "cb977045497f83ec3a02616973ab845c829cdab8144ce2e757fe031104a9abd4"
-
-DEPENDS = "python3-pyyaml python3-six python3-stevedore python3-pbr-native"
-
-inherit setuptools3 pypi
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.5.1.bb b/meta-python/recipes-devtools/python/python3-bandit_1.5.1.bb
new file mode 100644
index 0000000000..3002d5aa5d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.5.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "81ba3979ded1b421fa8d69e6faa06dcb"
+SRC_URI[sha256sum] = "9413facfe9de1e1bd291d525c784e1beb1a55c9916b51dae12979af63a69ba4c"
+
+DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+RDEPENDS_${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+BBCLASSEXTEND = "native"