aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-03-28 14:21:34 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-28 11:56:25 -0700
commitd2b4866919d6f0b2c9b979c981a0b937a208ac74 (patch)
tree6e7480c97c30e773574bb2f14e3fedb81481a276 /meta-python/recipes-devtools
parenta88f90fb8de86adbca8e7a65a510899bd0929b48 (diff)
downloadmeta-openembedded-d2b4866919d6f0b2c9b979c981a0b937a208ac74.tar.gz
python-cachetools: add recipe
Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-cachetools.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cachetools.inc b/meta-python/recipes-devtools/python/python-cachetools.inc
new file mode 100644
index 0000000000..52ae3186dd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cachetools.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Extensible memoizing collections and decorators"
+HOMEPAGE = "https://github.com/tkem/cachetools"
+DESCRIPTION = "This module provides various memoizing \
+collections and decorators, including variants of the \
+Python 3 Standard Library @lru_cache function decorator."
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5"
+
+inherit pypi
+
+SRC_URI[md5sum] = "a7b1c5eb5390d50067c62d7bcb4e875c"
+SRC_URI[sha256sum] = "9efcc9fab3b49ab833475702b55edd5ae07af1af7a4c627678980b45e459c460"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb b/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb
new file mode 100644
index 0000000000..8c12ad042f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-cachetools.inc
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb
new file mode 100644
index 0000000000..76b2f6785c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-cachetools.inc