aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:56 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commite10dd1e57741f8cd226d6080d02ee356eace0538 (patch)
treeafb28fa97a978cbfdc1e287a06b75eb3bf24fc75 /meta-python/recipes-devtools
parent4058807b84c52438b6dbda967875ab1a74b35655 (diff)
downloadmeta-openembedded-e10dd1e57741f8cd226d6080d02ee356eace0538.tar.gz
python3-pyserial: Add new recipe
Use a common .inc file for the python-pyserial and python3-pyserial recipes. Remove ${bindir}/miniterm.py from the Python 3 version of the package. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial.inc19
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_2.7.bb21
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_2.7.bb7
3 files changed, 27 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-python/recipes-devtools/python/python-pyserial.inc
new file mode 100644
index 0000000000..0fd6747569
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyserial.inc
@@ -0,0 +1,19 @@
+SUMMARY = "Serial Port Support for Python"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c557c64905dac5b725980b9505bf8d7b"
+SRCNAME = "pyserial"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+# FIXME might stop packaging serialwin32 and serialjava files
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-stringold \
+"
+
+SRC_URI[md5sum] = "794506184df83ef2290de0d18803dd11"
+SRC_URI[sha256sum] = "3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477"
diff --git a/meta-python/recipes-devtools/python/python-pyserial_2.7.bb b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
index 276db34bf2..ad2b350b0c 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb
@@ -1,21 +1,2 @@
-SUMMARY = "Serial Port Support for Python"
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c557c64905dac5b725980b9505bf8d7b"
-SRCNAME = "pyserial"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-# FIXME might stop packaging serialwin32 and serialjava files
-
-RDEPENDS_${PN} = "\
- python-fcntl \
- python-io \
- python-stringold \
-"
-
-SRC_URI[md5sum] = "794506184df83ef2290de0d18803dd11"
-SRC_URI[sha256sum] = "3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477"
+require python-pyserial.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb b/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb
new file mode 100644
index 0000000000..17ed3f8bc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb
@@ -0,0 +1,7 @@
+inherit setuptools3
+require python-pyserial.inc
+
+do_install_append() {
+ rm -f ${D}${bindir}/miniterm.py
+ rmdir ${D}${bindir}
+}