aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorShlomi Vaknin <shlomi.39sd@gmail.com>2020-05-26 13:05:38 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-28 12:36:49 -0700
commite116260648d65398af6077b62e7780ab81253be1 (patch)
tree9377bb419ab9f7b469fffc2308fad7b09e59a633 /meta-python/recipes-devtools
parent6840175f524c75e6cb8749e1bfb71573a4a0d96e (diff)
downloadmeta-openembedded-e116260648d65398af6077b62e7780ab81253be1.tar.gz
add python bitstring package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb b/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb
new file mode 100644
index 0000000000..eae8275d6d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitstring_3.1.7.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Simple construction, analysis and modification of binary data."
+HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
+AUTHOR = "Scott Griffiths <dr.scottgriffiths@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d973e8e0c311da41424357236b7b8908"
+
+SRC_URI[md5sum] = "18661a3e5c47c59bd926dd0fefae0baa"
+SRC_URI[sha256sum] = "fdf3eb72b229d2864fb507f8f42b1b2c57af7ce5fec035972f9566de440a864a"
+
+PYPI_PACKAGE = "bitstring"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-mmap \
+"
+
+BBCLASSEXTEND = "native nativesdk"