aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-20 03:44:30 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:53 +0200
commitcccb69cd94a962758bdcc9b0c8e02c3ac5b7536f (patch)
treea999e508b21fe0bbe0101b902ab63897ef811a10 /meta-python/recipes-extended
parent6e445ba8291d58f20e6a6b61afeabed85bd7b953 (diff)
downloadmeta-openembedded-cccb69cd94a962758bdcc9b0c8e02c3ac5b7536f.tar.gz
python3-meh: add recipe 0.45
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch44
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.45.bb17
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch b/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch
new file mode 100644
index 0000000000..41cfaddc9e
--- /dev/null
+++ b/meta-python/recipes-extended/python-meh/files/tweak-native-language-support.patch
@@ -0,0 +1,44 @@
+From 6e7689bced8ef56cfb5969560d23706f8e039807 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Mon, 11 Apr 2016 23:01:19 -0400
+Subject: [PATCH] tweak native language support
+
+- Only support en_GB only.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ Makefile | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index d0a9784..db152c4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -24,7 +24,7 @@ test:
+ PYTHONPATH=. python $(TESTSUITE) -v
+
+ install:
+- python setup.py install --root=$(DESTDIR)
++ python setup.py install --root=$(DESTDIR) --install-lib=${PYTHON_SITEPACKAGES_DIR} --prefix=${prefix}
+ $(MAKE) -C po install
+
+ ChangeLog:
+@@ -61,6 +61,13 @@ rpmlog:
+ @git log --pretty="format:- %s (%ae)" $(TAG).. |sed -e 's/@.*)/)/'
+ @echo
+
++po-empty:
++ for lingua in "en_GB" ; do \
++ [ -f po/$$lingua.po ] || \
++ msginit -i po/$(PKGNAME).pot -o po/$$lingua.po -l $$lingua --no-translator || \
++ exit 1 ; \
++ done
++
+ potfile:
+ $(MAKE) -C po potfile
+
+--
+1.9.1
+
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb
new file mode 100644
index 0000000000..6ace497811
--- /dev/null
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.45.bb
@@ -0,0 +1,17 @@
+SUMMARY = "A python library for handling exceptions"
+DESCRIPTION = "The python-meh package is a python library for handling, saving, and reporting \
+exceptions."
+HOMEPAGE = "http://git.fedorahosted.org/git/?p=python-meh.git"
+LICENSE = "GPLv2+"
+
+inherit setuptools3
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master \
+"
+SRCREV = "2bfc751fd680515d44f7096945a1e282a1f7d6aa"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+FILES_${PN} += "${datadir}/*"
+