aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:40 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commitd3f82f82f46c8abf8ab07a853599379c47422b7a (patch)
treecbaf42718dc40fbdd54ce16867e3b274353c153a /meta-python
parent63ca0ba5ae586474fe312aa1073c73afae302ddd (diff)
downloadmeta-openembedded-d3f82f82f46c8abf8ab07a853599379c47422b7a.tar.gz
python-markupsafe: add recipe
MarkupSafe is a Python library for escaping HTML strings, and it is a dependency for Jinja2. Add a recipe to build it. Copied from commit 6ba88a72843826370773cda29309545c7c800dc0 in meta-cloud-services/meta-openstack and updated to version 0.23. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-markupsafe_0.23.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb b/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb
new file mode 100644
index 0000000000..4821c0a3b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-markupsafe_0.23.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
+HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c6d1adcf45d69359f256c1cea3254127"
+
+PR = "r0"
+SRCNAME = "MarkupSafe"
+
+SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "f5ab3deee4c37cd6a922fb81e730da6e"
+SRC_URI[sha256sum] = "a4ec1aff59b95a14b45eb2e23761a0179e98319da5a7eb76b56ea8cdc7b871c3"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-re"