aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-08-04 08:12:03 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:25 +0200
commit3eb8991e7d2c726f46bbc3970c49fbeb222f69e4 (patch)
tree69ec43b2883233e060c15df6aa9cdd2981c027f4 /meta-python
parentfe0833e87e853024c9162fae17cbaf2fbfc6a53f (diff)
downloadmeta-openembedded-3eb8991e7d2c726f46bbc3970c49fbeb222f69e4.tar.gz
python-pyro4: Add new recipe.
Pyro4 allows remote execution of objects over the network. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.39.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.39.bb b/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.39.bb
new file mode 100644
index 0000000000..aed0c9c2b2
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.39.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python Remote Objects"
+HOMEPAGE = "https://pypi.python.org/pypi/Pyro4/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b48b62dd270c4691fabaa85be3236030"
+
+SRCNAME = "Pyro4"
+
+SRC_URI = "https://pypi.python.org/packages/source/P/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "75ed5cd142803b0a8d587dc8b6bb51ed"
+SRC_URI[sha256sum] = "39c6ca7f86b0f0bebfeada687a5a8b99f66470a52b0f815195ae63c683266f24"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools