aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:57 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:08 +0200
commitd6ee00bce06220f5bffe8d539a11f9a8410b3541 (patch)
tree1878b7551ca28eea499c4f655364bceb1d8da771 /meta-python
parente10dd1e57741f8cd226d6080d02ee356eace0538 (diff)
downloadmeta-openembedded-d6ee00bce06220f5bffe8d539a11f9a8410b3541.tar.gz
python3-pyinotify: Add new recipe
Use a common .inc file for the python-pyinotify and python3-pyinotify recipes. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyinotify.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb2
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyinotify.inc b/meta-python/recipes-devtools/python/python-pyinotify.inc
new file mode 100644
index 0000000000..285fe332bc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyinotify.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
+HOMEPAGE = "https://pypi.python.org/pypi/pyinotify"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
+
+RDEPENDS_${PN} += "python-threading python-io python-subprocess python-misc python-shell"
+
+SRCNAME = "pyinotify"
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
+SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb
index 42956ce421..d1f84c3ca8 100644
--- a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb
+++ b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb
@@ -1,17 +1,2 @@
-DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
-HOMEPAGE = "https://pypi.python.org/pypi/pyinotify"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
-
-RDEPENDS_${PN} += "python-threading python-io python-subprocess python-misc python-shell"
-
-SRCNAME = "pyinotify"
-SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
-SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
+require python-pyinotify.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb
new file mode 100644
index 0000000000..b3bab989ab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyinotify.inc