aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMike Looijmans <mike.looijmans@topic.nl>2015-09-06 16:42:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:21:39 +0200
commite91df9ce327bd4115930e4b0403bd8e8fa1e0446 (patch)
treeec7f9beeaa0f15030199cc2223b14dd381f6a64e /meta-python
parent7ad835c9f84acb34f6d29a3352f24812ef295b63 (diff)
downloadmeta-openembedded-e91df9ce327bd4115930e4b0403bd8e8fa1e0446.tar.gz
python-pyopenssl: Inherit setuptools to fix failing install
Fixes the following error during install phase: ImportError: No module named setuptools_ext ERROR: python setup.py install execution failed. Reported-by: athoik@openpli.org Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
index 694da275e2..7f9301299d 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984b
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit distutils
+inherit setuptools
PACKAGES =+ "${PN}-tests"
FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"