aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-28 14:08:47 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-31 07:38:06 -0700
commit63bd660d3dc999beb491bd90ae15be513e21ebd3 (patch)
treec47c1b0ea2c802eaf8ff5f7a3475801ee4aa7a0d /meta-python
parent204f049c7e6850798a1fd588b8abc181eb8de6a9 (diff)
downloadmeta-openembedded-63bd660d3dc999beb491bd90ae15be513e21ebd3.tar.gz
python3-ecdsa: Upgrade 0.16.1 -> 0.17.0
Upgrade to release 0.17.0: - Keys that use explicit curve parameters can now be read and written. Reading of explicit curves can be disabled by using the valid_curve_encodings keyword argument in VerifyingKey.from_pem(), VerifyingKey.from_der(), SigningKey.from_pem(), and SigningKey.from_der(). - Keys can now be written with use of explicit curve parameters, use curve_parameters_encoding keyword argument of VerifyingKey.to_pem(), VerifyingKey.to_der(), SigningKey.to_pem(), or SigningKey.to_der() to specify the format. By default named_curve will be used, unless the curve doesn't have an associated OID (as will be the case for an unsupported curve), then explicit encoding will be used. - Allow specifying acceptable point formats when loading public keys (this also fixes a minor bug where python-ecdsa would accept raw encoding for points in PKCS#8 files). Set of accepted encodings is controlled by valid_encodings keyword argument in ECDH.load_received_public_key_bytes(), VerifyingKey.from_string(), VerifyingKey.from_pem(), VerifyingKey.from_der(). - PointJacobi and Point now inherit from AbstractPoint that implements the methods for parsing points. That added from_bytes() and to_bytes() methods to both of them. - Curve parameters can now be read and written to PEM and DER files. The Curve class supports new to_der(), from_der(), to_pem(), and from_pem() methods. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb (renamed from meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
index 819d41e86e..1401f8e58d 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.16.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
DEPENDS += "python3-pip python3-pbr"
PYPI_PACKAGE = "ecdsa"
-SRC_URI[sha256sum] = "cfc046a2ddd425adbd1a78b3c46f0d1325c657811c0f45ecc3a0a6236c1e50ff"
+SRC_URI[sha256sum] = "b9f500bb439e4153d0330610f5d26baaf18d17b8ced1bc54410d189385ea68aa"
inherit pypi setuptools3