aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2018-09-14 09:51:44 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:01:41 -0700
commit892948980c153ff21f7863115b4a51c8f0f194d2 (patch)
tree129e424e2fbcf86affc0396d2b5c65c391ad5c3f /meta-python
parent8baaf208809ed9995f200c59866bcf123938a8a9 (diff)
downloadmeta-openembedded-892948980c153ff21f7863115b4a51c8f0f194d2.tar.gz
python(3)-ndg-httpsclient: use update-alternatives to avoid do_rootfs failure
Use update-alternaives to manage /usr/bin/ndg_httpclient to avoid the following do_rootfs failure. Error: Transaction check error: file /usr/bin/ndg_httpclient conflicts between attempted installs of python-ndg-httpsclient-0.5.1-r0.core2_64 and python3-ndg-httpsclient-0.5.1-r0.core2_64 Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb6
2 files changed, 10 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
index ca0eb32638..9cd881a3ef 100644
--- a/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
@@ -1,2 +1,6 @@
require python-ndg-httpsclient.inc
-inherit pypi setuptools
+inherit pypi setuptools update-alternatives
+
+ALTERNATIVE_${PN} = "ndg_httpclient"
+ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
+ALTERNATIVE_PRIORITY = "20"
diff --git a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
index 3f07b2ed27..65a8c816f4 100644
--- a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
@@ -1,2 +1,6 @@
-inherit pypi setuptools3
+inherit pypi setuptools3 update-alternatives
require python-ndg-httpsclient.inc
+
+ALTERNATIVE_${PN} = "ndg_httpclient"
+ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
+ALTERNATIVE_PRIORITY = "30"