aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-06-20 12:20:02 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:00 +0200
commit6e36914607f5174128c5161667c9e51ff1f451a8 (patch)
treeee0ace4acec965b462b46d69d34dc05ad6ecbd0a /meta-python
parent021844a31fb7081da8213338288596df0c281fe2 (diff)
downloadmeta-openembedded-6e36914607f5174128c5161667c9e51ff1f451a8.tar.gz
python-pylint: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint.inc31
-rw-r--r--meta-python/recipes-devtools/python/python-pylint_1.6.5.bb46
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb2
3 files changed, 36 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc
new file mode 100644
index 0000000000..18be8a1916
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pylint.inc
@@ -0,0 +1,31 @@
+SUMMARY="Pylint is a Python source code analyzer"
+HOMEPAGE= "http://www.pylint.org/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
+
+SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347"
+SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719"
+
+inherit pypi
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-astroid \
+ ${PYTHON_PN}-isort \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-netserver \
+ "
+
+do_install_append(){
+ rm ${D}${bindir}/pylint
+ cat >> ${D}${bindir}/pylint <<EOF
+#!/usr/bin/env ${PYTHON_PN}
+from pylint import run_pylint
+run_pylint()
+EOF
+ chmod 755 ${D}${bindir}/pylint
+}
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
index f5b4ad0527..47ab36a3ba 100644
--- a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
+++ b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
@@ -1,44 +1,4 @@
-SUMMARY="Pylint is a Python source code analyzer"
-HOMEPAGE= "http://www.pylint.org/"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
+inherit setuptools
+require python-pylint.inc
-SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347"
-SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719"
-
-RDEPENDS_${PN} += "python-codecs \
- python-contextlib \
- python-core \
- python-distutils \
- python-io \
- python-lang \
- python-multiprocessing \
- python-netserver \
- python-numbers \
- python-pickle \
- python-re \
- python-shell \
- python-six \
- python-stringold \
- python-subprocess \
- python-textutils \
- python-unittest \
- python-backports-functools-lru-cache \
- python-setuptools \
- python-astroid \
- python-wrapt \
- python-isort \
- python-lazy-object-proxy \
- "
-
-inherit pypi setuptools
-
-do_install_append(){
- rm ${D}${bindir}/pylint
- cat >> ${D}${bindir}/pylint <<EOF
-#!/usr/bin/env python
-from pylint import run_pylint
-run_pylint()
-EOF
- chmod 755 ${D}${bindir}/pylint
-}
+RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache"
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
new file mode 100644
index 0000000000..fed65b3036
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pylint.inc