aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTomasz Meresiński <tomasz.meresinski@comarch.pl>2018-02-07 17:43:52 +0100
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:23:33 -0800
commit8f9ab712c4b4a05229e65105792c23bc96f5befe (patch)
tree84d17ee1a214045e89408c9b48ca69703537fa4f /meta-python
parentcee1608a98d026840f7c2fef18ce43431ae0c0ec (diff)
downloadmeta-openembedded-8f9ab712c4b4a05229e65105792c23bc96f5befe.tar.gz
python3-twisted: remove python3-twisted-src
In python2 .py files are not necessary when importing a module. In python3 it's impossible to import without them. Removing python3-twisted-src makes .py files appear in packages again. Signed-off-by: Tomasz Meresiński<tomasz.meresinski@comarch.pl> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
index dfb9d4a4cc..6bd8c52eb0 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
@@ -1,6 +1,8 @@
inherit pypi setuptools3
require python-twisted.inc
+PACKAGES_remove = "${PN}-src"
+
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \