aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorParthiban Nallathambi <parthitce@gmail.com>2019-05-01 13:30:07 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-02 14:13:57 -0700
commit941481128020cf062a9f1c263c526cad726390cb (patch)
tree1a53589d9381f40e88d994b19c8e6a3a1c6a748f /meta-python
parent425c605a6d4270b48833d314ba880c0b3a5a1eec (diff)
downloadmeta-openembedded-941481128020cf062a9f1c263c526cad726390cb.tar.gz
python3-aiohttp: add version 3.5.4
Added python3-aiohttp with following missing DEPENDS - python3-async-timeout version 3.0.1 - python3-idna-ssl version 1.1.0 - python3-yarl version 1.3.0 Signed-off-by: Parthiban Nallathambi <parthitce@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-aiohttp.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-async-timeout.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-idna-ssl.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-yarl.inc10
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.5.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-idna-ssl_1.1.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.3.0.bb2
8 files changed, 61 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-aiohttp.inc b/meta-python/recipes-devtools/python/python-aiohttp.inc
new file mode 100644
index 0000000000..81f1809bdd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-aiohttp.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Async http client/server framework"
+DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[md5sum] = "85fe5c9037256c58d4678148bd91b3f3"
+SRC_URI[sha256sum] = "9c4c83f4fa1938377da32bc2d59379025ceeee8e24b89f72fcbccd8ca22dc9bf"
+
+PYPI_PACKAGE = "aiohttp"
+inherit pypi
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-async-timeout \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna-ssl \
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-yarl \
+"
diff --git a/meta-python/recipes-devtools/python/python-async-timeout.inc b/meta-python/recipes-devtools/python/python-async-timeout.inc
new file mode 100644
index 0000000000..7e4959ebc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-async-timeout.inc
@@ -0,0 +1,15 @@
+SUMMARY = "asyncio-compatible timeout context manager"
+DESCRIPTION = "\
+The context manager is useful in cases when you want to apply \
+timeout logic around block of code or in cases when asyncio.wait_for() \
+is not suitable. Also it's much faster than asyncio.wait_for() because \
+timeout doesn't create a new task."
+HOMEPAGE = "https://github.com/aio-libs/async-timeout"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI[md5sum] = "305c4fa529f2485c403d0dbe14390175"
+SRC_URI[sha256sum] = "0c3c816a028d47f659d6ff5c745cb2acf1f966da1fe5c19c77a70282b25f4c5f"
+
+PYPI_PACKAGE = "async-timeout"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-idna-ssl.inc b/meta-python/recipes-devtools/python/python-idna-ssl.inc
new file mode 100644
index 0000000000..e74bbd7c65
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-idna-ssl.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE = "https://github.com/aio-libs/idna-ssl"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a61b9c5aec8796b64a6bf15d42605073"
+
+SRC_URI[md5sum] = "dd44ec53bac36e68446766fd8d3835bd"
+SRC_URI[sha256sum] = "a933e3bb13da54383f9e8f35dc4f9cb9eb9b3b78c6b36f311254d6d0d92c6c7c"
+
+PYPI_PACKAGE = "idna-ssl"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-yarl.inc b/meta-python/recipes-devtools/python/python-yarl.inc
new file mode 100644
index 0000000000..49b5a607b5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-yarl.inc
@@ -0,0 +1,10 @@
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
+
+SRC_URI[md5sum] = "92889c31fce4c8f82b7ee9c2b2ed9cd1"
+SRC_URI[sha256sum] = "024ecdc12bc02b321bc66b41327f930d1c2c543fa9a561b39861da9388ba7aa9"
+
+PYPI_PACKAGE = "yarl"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.5.4.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.5.4.bb
new file mode 100644
index 0000000000..cd0303f05b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.5.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-aiohttp.inc
diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
new file mode 100644
index 0000000000..7e2ffdb05b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-async-timeout.inc
diff --git a/meta-python/recipes-devtools/python/python3-idna-ssl_1.1.0.bb b/meta-python/recipes-devtools/python/python3-idna-ssl_1.1.0.bb
new file mode 100644
index 0000000000..3643fcfd30
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-idna-ssl_1.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-idna-ssl.inc
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.3.0.bb b/meta-python/recipes-devtools/python/python3-yarl_1.3.0.bb
new file mode 100644
index 0000000000..c5df44216b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.3.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-yarl.inc