aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDomarys Correa <domarys.correa@ossystems.com.br>2020-05-26 16:20:11 -0300
committerKhem Raj <raj.khem@gmail.com>2020-05-28 12:36:49 -0700
commitbaf4a099a4902b39ccb1d0870d615c8c7d773416 (patch)
tree178340c1d496e31869ea5002ad4eff5788d086c2 /meta-python
parentc48caa2e19094db63ad19cea1997849a9493d648 (diff)
downloadmeta-openembedded-baf4a099a4902b39ccb1d0870d615c8c7d773416.tar.gz
python3-pytest-asyncio: Update 0.10.0 -> 0.12.0
Signed-off-by: Domarys Correa <domarys.correa@ossystems.com.br> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.12.0.bb14
2 files changed, 14 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
deleted file mode 100644
index a7e963b044..0000000000
--- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
-HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
-
-SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
-SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
-
-inherit pypi setuptools3
-
-DEPENDS += "${PYTHON_PN}-pytest-native"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.12.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.12.0.bb
new file mode 100644
index 0000000000..d83c42de38
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.12.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=3faed73a08162b5b5367cdcaee996f75"
+
+SRC_URI[sha256sum] = "475bd2f3dc0bc11d2463656b3cbaafdbec5a47b47508ea0b329ee693040eebd2"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"