aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-06-13 11:25:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:32 -0700
commitcdc746763189818b16c6eec35375a162359d4d27 (patch)
treeb39bc7e76c6412f705ea8b534ddc53148a8a65cb /meta-python
parent866daa14e30e2141a025fd9e71ba5406a8b0329a (diff)
downloadmeta-openembedded-cdc746763189818b16c6eec35375a162359d4d27.tar.gz
python-pywbem: solved the conflict with python3-pywbem
-Use update-alternatives class to resolve conflicts with python3-pywbem. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
index 7410749071..a699f1c7e3 100644
--- a/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
+++ b/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
@@ -1,5 +1,5 @@
require python-pywbem.inc
-inherit setuptools
+inherit setuptools update-alternatives
DEPENDS += " \
${PYTHON_PN}-m2crypto-native \
@@ -11,3 +11,10 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-m2crypto \
${PYTHON_PN}-subprocess \
"
+
+ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
+ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
+
+ALTERNATIVE_PRIORITY = "30"