aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2016-12-01 13:24:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:17 +0100
commitd356e03ced0873a0fe1a7a69cb05ee803e363888 (patch)
tree36f0988c763964a6b3e3dd082ff2a0798a9247da /meta-python
parent13611ae96c9b2fab928eb794415f5bec6331abb2 (diff)
downloadmeta-openembedded-d356e03ced0873a0fe1a7a69cb05ee803e363888.tar.gz
python-backports-functools-lru-cache: add new recipe
The recipe defines the backports.functools_lru_cache package. This package backports LRU cache from Python 3.3, supporting the full Py3.3 API. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb
new file mode 100644
index 0000000000..211cfdef4b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Backport of functools.lru_cache from Python 3.3"
+HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=42;endline=42;md5=98fc3658e5970d26f6b2109808c766be"
+
+PYPI_PACKAGE = "backports.functools_lru_cache"
+
+SRC_URI[md5sum] = "b26a223250bd24ea2e0ad6ce47b19084"
+SRC_URI[sha256sum] = "444a21bcec4ae177da554321f81a78dc879eaa8f6ea9920cb904830585d31e95"
+
+DEPENDS = "python-setuptools-scm-native"
+
+inherit setuptools pypi