aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-04-04 08:37:57 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:56:14 +0200
commit9667f17d6ec3ca1b719d230e69569cf57c766a4d (patch)
tree2b307dce022a9038dbda39ae796cfeec4d4445a2 /meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb
parent3f3b11d4c8e4339af8d38bce22e6ebd29ac08fca (diff)
downloadmeta-openembedded-9667f17d6ec3ca1b719d230e69569cf57c766a4d.tar.gz
ruby: package update to verison 2.2.1
LIC_FILES_CHKSUM changes: BDSL: update copyright notice with "2013" GPL: update to GPLv2 LEGAL: added license info for ccan files dropped patches since they are now incorperated. several security fixes included: CVE-2014-2525 CVE-2014-0160 CVE-2014-2734 CVE-2014-8080 CVE-2014-8090 for addional information: http://svn.ruby-lang.org/repos/ruby/tags/v2_2_1/ChangeLog Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb b/meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb
new file mode 100644
index 0000000000..29f2291559
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby_2.2.1.bb
@@ -0,0 +1,39 @@
+require ruby.inc
+
+SRC_URI[md5sum] = "b49fc67a834e4f77249eb73eecffb1c9"
+SRC_URI[sha256sum] = "5a4de38068eca8919cb087d338c0c2e3d72c9382c804fb27ab746e6c7819ab28"
+
+# it's unknown to configure script, but then passed to extconf.rb
+# maybe it's not really needed as we're hardcoding the result with
+# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
+UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
+PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
+
+EXTRA_OECONF = "\
+ --enable-wide-getaddrinfo \
+ --disable-versioned-paths \
+ --disable-rpath \
+ --enable-shared \
+ --enable-load-relative \
+"
+
+EXTRA_OEMAKE = " \
+ LIBRUBYARG='-lruby-static' \
+"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_${PN} += "${datadir}/rubygems \
+ ${datadir}/ri"
+
+FILES_${PN}-dbg += "${libdir}/ruby/*/.debug \
+ ${libdir}/ruby/*/*/.debug \
+ ${libdir}/ruby/*/*/*/.debug \
+ ${libdir}/ruby/*/*/*/*/.debug"
+
+BBCLASSEXTEND = "native"