aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-09-01 12:03:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-01 12:49:00 +0200
commitb45472a29b60d46cca313bd629561e674befe386 (patch)
treef28d69bc76d1bc25f2814611cd823039d5038ff4 /meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
parent6b881ba6fd3e828021c266d3bd9c7a606d120858 (diff)
downloadmeta-openembedded-b45472a29b60d46cca313bd629561e674befe386.tar.gz
at: rename bbappend to match any version from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended/at/at_%.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
new file mode 100644
index 0000000000..3a22fe3bda
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
@@ -0,0 +1,16 @@
+inherit systemd
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://atd.service"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "atd.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
+}
+