aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:23:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:02 +0200
commita67fc4b8a3fc69143d581ee2f991647f5764e9f2 (patch)
treebc1475ae61bc37a40b1eeda1cfc9c0445e778c69 /meta-systemd/oe-core
parent1fb0eacf0349c4b886e89aea275f43b973b78245 (diff)
downloadmeta-openembedded-a67fc4b8a3fc69143d581ee2f991647f5764e9f2.tar.gz
busybox: move bbappend to oe-core subdirectory
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-klogd.service.in8
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-syslog.service.in13
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend23
3 files changed, 44 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-klogd.service.in b/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-klogd.service.in
new file mode 100644
index 0000000000..d7c77558f3
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-klogd.service.in
@@ -0,0 +1,8 @@
+[Unit]
+Description=Kernel Logging Service
+
+[Service]
+ExecStart=@base_sbindir@/klogd -n
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-syslog.service.in b/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-syslog.service.in
new file mode 100644
index 0000000000..2e04321385
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox/busybox-syslog.service.in
@@ -0,0 +1,13 @@
+[Unit]
+Description=System Logging Service
+Wants=busybox-klogd.service
+
+[Service]
+EnvironmentFile=-/etc/default/busybox-syslog
+ExecStart=@base_sbindir@/syslogd -n $OPTIONS
+Sockets=syslog.socket
+
+[Install]
+WantedBy=multi-user.target
+Also=busybox-klogd.service
+Alias=syslog.service
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
new file mode 100644
index 0000000000..06993025f1
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -0,0 +1,23 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 2}"
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://busybox-syslog.service.in \
+ file://busybox-klogd.service.in"
+
+SYSTEMD_PACKAGES = "${PN}-syslog"
+SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-syslog.service
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-klogd.service
+
+ ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
+}
+FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"