aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:07 +0200
commitc203043683deff90b4d80c326bf6b27a28a59386 (patch)
treebf6aa8e0e30de5a21f3d89a0a4bbefb7f6b99d16 /meta-systemd
parent365d5ec941347f54744b9f5fbb7b06cc3949e14a (diff)
downloadmeta-openembedded-c203043683deff90b4d80c326bf6b27a28a59386.tar.gz
cherokee: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service10
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend10
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
new file mode 100644
index 0000000000..a2d703185d
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Cherokee web server
+After=syslog.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
new file mode 100644
index 0000000000..7cc7dd8474
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SRC_URI += "file://cherokee.service"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "cherokee.service"