aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-10 11:04:20 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-11 09:28:09 +0100
commita6614039ee04605d4b5efe6b2c2942dc9d0aac4d (patch)
treef0a65a3b78081c4c4b4c847960bc6a3000bff09c /meta-webserver
parentdff2c1bd5291e95b35a102c1b5fdbe78aa627c41 (diff)
downloadmeta-openembedded-a6614039ee04605d4b5efe6b2c2942dc9d0aac4d.tar.gz
apache2: reorganise packaging definitions
Move RDEPENDS to the end and PACKAGES before other packaging definitions. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
index 2c0fa6b92e..5857be7ded 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
@@ -3,7 +3,6 @@ extensible web server."
SUMMARY = "Apache HTTP Server"
HOMEPAGE = "http://httpd.apache.org/"
DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
-RDEPENDS_${PN} += "openssl libgcc"
SECTION = "net"
LICENSE = "Apache-2.0"
PR = "r2"
@@ -103,13 +102,13 @@ INITSCRIPT_NAME = "apache2"
INITSCRIPT_PARAMS = "defaults 91 20"
LEAD_SONAME = "libapr-1.so.0"
+PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
+
CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \
${sysconfdir}/${PN}/magic \
${sysconfdir}/${PN}/mime.types \
${sysconfdir}/init.d/${PN} "
-PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
-
# we override here rather than append so that .so links are
# included in the runtime package rather than here (-dev)
# and to get build, icons, error into the -dev package
@@ -140,3 +139,5 @@ FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug"
+RDEPENDS_${PN} += "openssl libgcc"
+