aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-08-09 10:31:20 -0700
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-13 08:50:06 +0100
commit45777abe8780fdce62fc614c4a07d265cad18319 (patch)
tree4feccd9b9fadebafb68735a2dc95935a3a680a7c /meta-webserver
parent5c3e27684cf2ef187b2c99d7f84ea7b367061e70 (diff)
downloadmeta-openembedded-45777abe8780fdce62fc614c4a07d265cad18319.tar.gz
nostromo: make sure usr/group www-data exist
CQID: 422203 nostromo runs as user/group www-data and needs these to exist when we install it. Signed-off-by: Joe Slater <jslater@windriver.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
index e34fba2607..3aaa5c2d4d 100644
--- a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
@@ -18,7 +18,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
DEPENDS = "openssl"
-inherit update-rc.d
+inherit update-rc.d useradd
INITSCRIPT_NAME = "nostromo"
INITSCRIPT_PARAMS = "defaults 70"
@@ -27,6 +27,11 @@ do_compile() {
oe_runmake
}
+# we need user/group www-data to exist when we install
+#
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system -g www-data www-data"
+
do_install() {
install -d ${D}/${sbindir}
install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd