aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-09-16 13:56:00 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:39:45 +0200
commit8684b379bc62fed44ad52925182fc804f8137a2a (patch)
tree640f2a4fbd52d2bcb2e278b08c54bcf6ef0a0510 /meta-xfce
parent5a23581c40768b60f90f4800c4dd3f6e67dd10e1 (diff)
downloadmeta-openembedded-8684b379bc62fed44ad52925182fc804f8137a2a.tar.gz
meta-openembedded-8684b379bc62fed44ad52925182fc804f8137a2a.tar.bz2
meta-openembedded-8684b379bc62fed44ad52925182fc804f8137a2a.zip
xfce4-pulseaudio-plugin: add packageconfig for libnotify
Add PACKAGECONFIG for libnotify and disable it by default to avoid the QA issue: WARNING: QA Issue: xfce4-pulseaudio-plugin rdepends on libnotify, but it isn't a build dependency? [build-deps] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/pulseaudio/xfce4-pulseaudio-plugin_0.2.3.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/pulseaudio/xfce4-pulseaudio-plugin_0.2.3.bb b/meta-xfce/recipes-panel-plugins/pulseaudio/xfce4-pulseaudio-plugin_0.2.3.bb
index f9ad32fe6..9a95cded9 100644
--- a/meta-xfce/recipes-panel-plugins/pulseaudio/xfce4-pulseaudio-plugin_0.2.3.bb
+++ b/meta-xfce/recipes-panel-plugins/pulseaudio/xfce4-pulseaudio-plugin_0.2.3.bb
@@ -11,4 +11,7 @@ DEPENDS += "pulseaudio"
SRC_URI[md5sum] = "13a47ba5a72c16fb06f7e1cc89858cc7"
SRC_URI[sha256sum] = "e82836bc8cf7d905b4e60d43dc630ba8e32dea785989700c71d4aeee9f583b33"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libnotify] = "--enable-libnotify,--disable-libnotify,libnotify"
+
RRECOMMENDS_${PN} = "pavucontrol"