aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-02-24 14:33:44 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-25 17:57:15 -0800
commite37bcbc1379cab5c4e7644f1d405498dea7e3f52 (patch)
treebbb3bc7b9515d0833209db23a5074cd5525723e3 /meta-xfce
parent691e76b83a5accb22e112e6aaef2cca00d4318bd (diff)
downloadmeta-openembedded-e37bcbc1379cab5c4e7644f1d405498dea7e3f52.tar.gz
xfce4-sensors-plugin: Change defaults to useful ones
Every time I added xfce4-sensors-plugin to panel xfce4-sensors-plugin suggested sensors not exactly useful. So change defaults: * remove lmsensors * make sysfsacpi work and don't disable it because that's where embedded machines drop useful information Background: Have spent lots of efforts to get Raspi4 cooled properly while running at gouvernor 'performance' and rendering music. Would like to see if it really wears a cool hat [1] [1] https://github.com/schnitzeltony/rpi-cool-hat Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch44
-rw-r--r--meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb3
2 files changed, 45 insertions, 2 deletions
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch
new file mode 100644
index 0000000000..ac1d603b29
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch
@@ -0,0 +1,44 @@
+From 9b7e1beca872ca4a5fce8938c58379103787f79a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sun, 23 Feb 2020 22:06:32 +0100
+Subject: [PATCH] Do not check for /sys/class/power_supply - we are cross
+ compiling
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate [OE-specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ configure.ac | 12 +-----------
+ 1 file changed, 1 insertion(+), 11 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c281af9..60ba0c0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -209,19 +209,9 @@ dnl Check for interface for /sys/class/power_supply to be used
+ AC_ARG_ENABLE([sysfsacpi], [AC_HELP_STRING([--enable-sysfsacpi], [Use /sys/class/power_supply to read your battery value @<:@default=auto@:>@])],
+ [],
+ [
+- enable_sysfsacpi=auto
++ enable_sysfsacpi=yes
+ ])
+
+-if test x"$enable_sysfsacpi" = x"auto"; then
+- AC_CHECK_FILE([/sys/class/power_supply],
+- [
+- enable_sysfsacpi=yes
+- ],
+- [
+- enable_sysfsacpi=no
+- ])
+-fi
+-
+ if test x"$enable_sysfsacpi" = x"yes"; then
+ AC_DEFINE([HAVE_SYSFS_ACPI], [1], [Define to 1 if /sys/class/power_supply is found])
+ enable_procacpi=yes
+--
+2.21.0
+
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
index 8b650143fb..3fd0ff6cf4 100644
--- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
+++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb
@@ -7,10 +7,10 @@ inherit xfce-panel-plugin
SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89"
SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112"
+SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
EXTRA_OECONF = " \
--disable-procacpi \
- --disable-sysfsacpi \
--disable-xnvctrl \
"
@@ -18,7 +18,6 @@ do_configure_prepend() {
sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
}
-PACKAGECONFIG ??= "libsensors"
PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"