aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb2
-rw-r--r--meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb2
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb2
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb2
-rw-r--r--meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.2.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.5.2.bb2
-rw-r--r--meta-oe/recipes-support/pcp/pcp.inc2
7 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
index e0f52ea62b..5263aaef30 100644
--- a/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
+++ b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
@@ -9,7 +9,7 @@ PV = "1.3"
SRC_URI:append:class-target = " file://oe-remote.repo.sample"
-inherit distutils3-base
+inherit setuptools3-base
S = "${WORKDIR}/git"
diff --git a/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb b/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb
index 7ff0725a20..ec427a9a73 100644
--- a/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb
+++ b/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
DEPENDS = "cracklib virtual/gettext"
-inherit autotools distutils3-base gettext
+inherit autotools setuptools3-base gettext
B = "${S}"
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
index 7ab03eccf2..2a50550a0e 100644
--- a/meta-oe/recipes-extended/mraa/mraa_git.bb
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/git"
# CMakeLists.txt checks the architecture, only x86 and ARM supported for now
COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
-inherit cmake distutils3-base
+inherit cmake setuptools3-base
DEPENDS += "json-c"
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index 78a45ab4e0..61e2e38b05 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -25,7 +25,7 @@ S = "${WORKDIR}/git"
# Depends on mraa which only supports x86 and ARM for now
COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
-inherit distutils3-base cmake pkgconfig
+inherit setuptools3-base cmake pkgconfig
EXTRA_OECMAKE += "-UPYTHON_EXECUTABLE -DWERROR=off"
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.2.bb b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.2.bb
index c32165150a..eea231a2ea 100644
--- a/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.2.bb
+++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.2.bb
@@ -13,7 +13,7 @@ SRCREV = "5cbbc07c9d015af284a424a172a379b385f05b6f"
S = "${WORKDIR}/git"
-inherit cmake gettext pkgconfig python3-dir python3native distutils3-base mime-xdg
+inherit cmake gettext pkgconfig python3-dir python3native setuptools3-base mime-xdg
DEPENDS += "dnf python3 "
#DEPENDS:class-nativesdk += "nativesdk-python3"
diff --git a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
index da1c72f298..2f2a505ed3 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
@@ -141,7 +141,7 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
inherit pkgconfig cmake
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'distutils3-base', '', d)}
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'setuptools3-base', '', d)}
inherit ${@bb.utils.contains('PACKAGECONFIG', 'python2', 'distutils-base', '', d)}
export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
diff --git a/meta-oe/recipes-support/pcp/pcp.inc b/meta-oe/recipes-support/pcp/pcp.inc
index d50e7b0910..37b6c45f18 100644
--- a/meta-oe/recipes-support/pcp/pcp.inc
+++ b/meta-oe/recipes-support/pcp/pcp.inc
@@ -13,7 +13,7 @@ SRC_URI = "https://performancecopilot.jfrog.io/artifactory/pcp-source-release/pc
SRC_URI[sha256sum] = "589a610f753a49af6d2015cede87e9d469bd07880ebef26fe1607b6ded375e97"
-inherit distutils3-base pkgconfig autotools
+inherit setuptools3-base pkgconfig autotools
B = "${S}"