aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch (renamed from meta-networking/recipes-support/libtevent/libtevent/tevent-Add-configure-options-for-packages.patch)28
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb (renamed from meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb)6
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/tevent-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch
index ddb8e4e23b..84b1a36881 100644
--- a/meta-networking/recipes-support/libtevent/libtevent/tevent-Add-configure-options-for-packages.patch
+++ b/meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch
@@ -14,6 +14,10 @@ Add configure options for the following packages:
Upstream-Status: Inappropriate [oe deterministic build specific]
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+
+Modified to apply to version 0.9.33.
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
---
lib/replace/system/wscript_configure | 6 ++-
lib/replace/wscript | 85 ++++++++++++++++++++++++++++--------
@@ -155,23 +159,19 @@ index fc43e1a..12d2a70 100644
conf.CHECK_CODE('''
struct ucred cred;
-diff --git a/wscript b/wscript
-old mode 100755
-new mode 100644
-index 71b9475..50793db
--- a/wscript
+++ b/wscript
-@@ -26,7 +26,12 @@ def set_options(opt):
- opt.add_option('--disable-python',
- help=("disable the pytevent module"),
- action="store_true", dest='disable_python', default=False)
+@@ -22,7 +22,12 @@ def set_options(opt):
+ opt.PRIVATE_EXTENSION_DEFAULT('tevent', noextension='tevent')
+ opt.RECURSE('lib/replace')
+ opt.RECURSE('lib/talloc')
-
-+ opt.add_option('--with-valgrind',
-+ help=("enable use of valgrind"),
-+ action="store_true", dest='enable_valgrind')
-+ opt.add_option('--without-valgrind',
-+ help=("disable use of valgrind"),
-+ action="store_false", dest='enable_valgrind', default=False)
++ opt.add_option('--with-valgrind',
++ help=("enable use of valgrind"),
++ action="store_true", dest='enable_valgrind')
++ opt.add_option('--without-valgrind',
++ help=("disable use of valgrind"),
++ action="store_false", dest='enable_valgrind', default=False)
def configure(conf):
conf.RECURSE('lib/replace')
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb
index ad711e730e..f508300692 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb
@@ -7,12 +7,12 @@ DEPENDS += "libtalloc"
RDEPENDS_python-tevent = "python"
SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
- file://tevent-Add-configure-options-for-packages.patch \
+ file://options-0.9.33.patch \
"
LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
-SRC_URI[md5sum] = "5453847664ae6bc4ec0153e59ac635b9"
-SRC_URI[sha256sum] = "4a13f2256ad804c860e84068258bd0f8be31cf0c79aa8f3019fa32f6928c2bfc"
+SRC_URI[md5sum] = "527a43f35b4251e46f28921342895223"
+SRC_URI[sha256sum] = "22712ee981fd4298fcd5f3afb27d87a72257cebad37812cfbd3da5d968ed1bdc"
inherit waf-samba