aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-whoosh.inc11
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb7
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-whoosh.inc b/meta-python/recipes-devtools/python/python-whoosh.inc
index 0a2cf3bf44..f43d8c1b0c 100644
--- a/meta-python/recipes-devtools/python/python-whoosh.inc
+++ b/meta-python/recipes-devtools/python/python-whoosh.inc
@@ -12,3 +12,14 @@ SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b4537
PYPI_PACKAGE = "Whoosh"
PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-subprocess \
+"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index 5d8af303c7..4a4e679fbb 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -1,2 +1,9 @@
inherit pypi setuptools3
require python-whoosh.inc
+
+# Requires _pydecimal.py which is in misc
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-selectors \
+"