aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch29
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb8
2 files changed, 3 insertions, 34 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
deleted file mode 100644
index 401949e2ec..0000000000
--- a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 6c2649718fc9818da0d602a0b4767ea21a367e9e Mon Sep 17 00:00:00 2001
-From: Tim Orling <timothy.t.orling@linux.intel.com>
-Date: Sat, 27 Jan 2018 02:06:36 -0800
-Subject: [PATCH] examples/iio_driver.c: include endian.h to fix musl build
-
-* be16toh and le16toh are defined in endian.h
-
-Upstream-Status: Pending
-
-Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
----
- examples/iio_driver.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/examples/iio_driver.c b/examples/iio_driver.c
-index c5a0181..e3dc438 100644
---- a/examples/iio_driver.c
-+++ b/examples/iio_driver.c
-@@ -23,6 +23,7 @@
- */
-
- #include <unistd.h>
-+#include <endian.h>
- #include "mraa/iio.h"
-
- static void
---
-2.13.6
-
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
index e1d593cbee..16883be3a7 100644
--- a/meta-oe/recipes-extended/mraa/mraa_git.bb
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -3,15 +3,13 @@ HOMEPAGE = "https://github.com/intel-iot-devkit/mraa"
SECTION = "libs"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=66493d54e65bfc12c7983ff2e884f37f"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4b92a3b497d7943042a6db40c088c3f2"
-SRCREV = "8ddbcde84e2d146bc0f9e38504d6c89c14291480"
-PV = "1.7.0-git${SRCPV}"
+SRCREV = "fbb7d9232067eac3f4508a37a8f7ea0c4fcebacb"
+PV = "1.9.0-git${SRCPV}"
SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http"
-SRC_URI_append_libc-musl = " file://0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch"
-
S = "${WORKDIR}/git"
# CMakeLists.txt checks the architecture, only x86 and ARM supported for now