aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-kernel')
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-kexecboot_3.2.bb13
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb23
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-kernel/linux/linux-kexecboot_3.2.bb b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_3.2.bb
new file mode 100644
index 0000000000..32074291f1
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_3.2.bb
@@ -0,0 +1,13 @@
+require linux-kexecboot.inc
+
+PR = "${INC_PR}.1"
+S = "${WORKDIR}/linux-${PV}"
+
+SRC_URI += "${KERNELORG_MIRROR}/linux/kernel/v3.x/linux-${PV}.tar.bz2;name=kernel \
+ ${KERNELORG_MIRROR}/linux/kernel/v3.x/patch-${PV}.1.bz2;apply=yes;name=stablepatch \
+ "
+
+SRC_URI[kernel.md5sum] = "7ceb61f87c097fc17509844b71268935"
+SRC_URI[kernel.sha256sum] = "c881fc2b53cf0da7ca4538aa44623a7de043a41f76fd5d0f51a31f6ed699d463"
+SRC_URI[stablepatch.md5sum] = "31fc34340f11118873463a1d59d47b7f"
+SRC_URI[stablepatch.sha256sum] = "e9a26dc5faa309ae5172e3c65081fa98b60befab160fb14d9a75816bbde15626"
diff --git a/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb
new file mode 100644
index 0000000000..b1fc75bb9b
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb
@@ -0,0 +1,23 @@
+require linux-kexecboot.inc
+
+PR = "${INC_PR}.1"
+
+KERNEL_RELEASE = "3.2.0-rc7"
+OLD_KERNEL_RELEASE = "3.1.99"
+PV = "${OLD_KERNEL_RELEASE}+${KERNEL_RELEASE}+gitr${SRCPV}"
+
+SRCREV = "371de6e4e0042adf4f9b54c414154f57414ddd37"
+
+CMDLINE_DEBUG = "debug"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master"
+
+do_configure_prepend() {
+#otherwise it gets extra '+' "2.6.37+"
+#because:
+#$ scripts/setlocalversion . => +
+#$ make kernelversion => 2.6.37
+#$ make kernelrelease => 2.6.37+
+ rm -rf ${S}/.git
+}