aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/openal/openal-soft
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/openal/openal-soft')
-rw-r--r--meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch33
-rw-r--r--meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch31
2 files changed, 0 insertions, 64 deletions
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch
deleted file mode 100644
index 16f123fad8..0000000000
--- a/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 29217932c34d7e3368764ab64879dc6f1edab1a6 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 14 Jan 2019 11:19:44 -0800
-Subject: [PATCH] Use host compiler to compile native tools
-
-Helps in cross compiling
-
-Upstream-Status: Inappropriate [OE-Specific]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- CMakeLists.txt | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 39b80250..d6bdf8ed 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1288,11 +1288,10 @@ FILE(MAKE_DIRECTORY "${NATIVE_BIN_DIR}")
- SET(BIN2H_COMMAND "${NATIVE_BIN_DIR}bin2h")
- SET(BSINCGEN_COMMAND "${NATIVE_BIN_DIR}bsincgen")
- ADD_CUSTOM_COMMAND(OUTPUT "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
-- COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" "${NATIVE_SRC_DIR}"
- COMMAND ${CMAKE_COMMAND} -E remove "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
-- COMMAND ${CMAKE_COMMAND} --build . --config "Release"
-+ COMMAND gcc "${NATIVE_SRC_DIR}bin2h.c" -o "${BIN2H_COMMAND}" -lm
-+ COMMAND gcc "${NATIVE_SRC_DIR}bsincgen.c" -o "${BSINCGEN_COMMAND}" -lm
- WORKING_DIRECTORY "${NATIVE_BIN_DIR}"
-- DEPENDS "${NATIVE_SRC_DIR}CMakeLists.txt"
- IMPLICIT_DEPENDS C "${NATIVE_SRC_DIR}bin2h.c"
- C "${NATIVE_SRC_DIR}bsincgen.c"
- VERBATIM
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch
deleted file mode 100644
index 8420386e36..0000000000
--- a/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 07ef86e33ed6f7585f0dfaa1732ea17c816655a4 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 14 Jan 2019 11:45:42 -0800
-Subject: [PATCH] makehrtf: Disable Wstringop-truncation
-
-Upstream-Status: Inappropriate [Should be fixed in code]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- utils/makehrtf.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/utils/makehrtf.c b/utils/makehrtf.c
-index 0bd36849..0abe4252 100644
---- a/utils/makehrtf.c
-+++ b/utils/makehrtf.c
-@@ -862,6 +862,7 @@ static int TrReadOperator(TokenReaderT *tr, const char *op)
- * pattern string are replaced with the replacement string. The result is
- * truncated if necessary.
- */
-+#pragma GCC diagnostic ignored "-Wstringop-truncation"
- static int StrSubst(const char *in, const char *pat, const char *rep, const size_t maxLen, char *out)
- {
- size_t inLen, patLen, repLen;
-@@ -900,6 +901,7 @@ static int StrSubst(const char *in, const char *pat, const char *rep, const size
- return !truncated;
- }
-
-+#pragma GCC diagnostic pop
-
- /*********************
- *** Math routines ***