aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb (renamed from meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb)8
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch34
2 files changed, 39 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb b/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb
index 79d1dada04..a5aa584f5a 100644
--- a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb
+++ b/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb
@@ -10,9 +10,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0531457992a97ecebc6975914a874a9d"
UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
SRC_URI = "http://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
- file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch"
-SRC_URI[md5sum] = "c0375a1f725f1c191b43af60e4f7175b"
-SRC_URI[sha256sum] = "33a26ad561546cd2cfe1e6de6352a85df72b41c37def8c7eb00e90e57c627a5c"
+ file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
+ file://0001-dhcpcd-Fix-build-error-with-musl.patch"
+
+SRC_URI[md5sum] = "dc4f29a62afc53cdac311e925cfd1bc7"
+SRC_URI[sha256sum] = "485d308fe10febd36b6f936e4260e4ab34a146e4f00a9f7a5509c4377ad5ea82"
inherit pkgconfig autotools-brokensep
diff --git a/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch b/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch
new file mode 100644
index 0000000000..b48b467b8c
--- /dev/null
+++ b/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch
@@ -0,0 +1,34 @@
+Subject: [PATCH] dhcpcd: Fix build error with musl.
+
+Re-organize the header includes in if-linux.c to fix error as follows:
+In file included from if-linux.c:49:
+path/usr/include/netinet/if_ether.h:112:8: error: redefinition of 'struct ethhdr'
+
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+---
+ src/if-linux.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/if-linux.c b/src/if-linux.c
+index fd47278..bfa878b 100644
+--- a/src/if-linux.c
++++ b/src/if-linux.c
+@@ -37,6 +37,7 @@
+ #include <linux/if_addr.h>
+ #include <linux/if_link.h>
+ #include <linux/if_packet.h>
++#include <netinet/if_ether.h>
+ #include <linux/if_tun.h>
+ #include <linux/if_vlan.h>
+ #include <linux/filter.h>
+@@ -46,7 +47,6 @@
+
+ #include <arpa/inet.h>
+ #include <net/if.h>
+-#include <netinet/if_ether.h>
+ #include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <net/route.h>
+--
+2.7.4
+