aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/conf/layer.conf')
-rw-r--r--meta-oe/conf/layer.conf13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index 34aa29561c..4d9acb8cc8 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -34,6 +34,8 @@ BBFILES_DYNAMIC += " \
gnome-layer:${LAYERDIR}/dynamic-layers/gnome-layer/recipes-*/*/*.bbappend \
perl-layer:${LAYERDIR}/dynamic-layers/perl-layer/recipes-*/*/*.bb \
perl-layer:${LAYERDIR}/dynamic-layers/perl-layer/recipes-*/*/*.bbappend \
+ selinux:${LAYERDIR}/dynamic-layers/selinux/recipes-*/*/*.bb \
+ selinux:${LAYERDIR}/dynamic-layers/selinux/recipes-*/*/*.bbappend \
"
# This should only be incremented on significant changes that will
@@ -42,12 +44,18 @@ LAYERVERSION_openembedded-layer = "1"
LAYERDEPENDS_openembedded-layer = "core"
-LAYERSERIES_COMPAT_openembedded-layer = "kirkstone langdale"
+LAYERSERIES_COMPAT_openembedded-layer = "scarthgap"
LICENSE_PATH += "${LAYERDIR}/licenses"
PREFERRED_RPROVIDER_libdevmapper = "lvm2"
+PREFERRED_RPROVIDER_libdevmapper-native = "lvm2-native"
+PREFERRED_RPROVIDER_nativesdk-libdevmapper = "nativesdk-lvm2"
PREFERRED_PROVIDER_android-tools-conf ?= "android-tools-conf"
+# Configures whether coreutils or uutils-coreutils is used.
+PREFERRED_PROVIDER_coreutils = "coreutils"
+PREFERRED_PROVIDER_virtual/opencl-icd ?= "opencl-icd-loader"
+PREFERRED_RPROVIDER_virtual-opencl-icd ?= "opencl-icd-loader"
SIGGEN_EXCLUDERECIPES_ABISAFE += " \
fbset-modes \
@@ -79,6 +87,7 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
ttf-dejavu->fontconfig \
ttf-droid->fontconfig \
ttf-gentium->fontconfig \
+ ttf-google-fira->fontconfig \
ttf-hunkyfonts->fontconfig \
ttf-inconsolata->fontconfig \
ttf-ipa->fontconfig \
@@ -105,4 +114,4 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
DEFAULT_TEST_SUITES:pn-meta-oe-ptest-image = " ${PTESTTESTSUITE}"
-NON_MULTILIB_RECIPES:append = " crash"
+NON_MULTILIB_RECIPES:append = " crash pahole libbpf"