aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb')
-rw-r--r--meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
new file mode 100644
index 0000000000..fcfd0386d9
--- /dev/null
+++ b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Touchscreen calibration data"
+SECTION = "base"
+PR = "r11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4b5fcfc87fb615860d398b5e38685edf"
+
+SRC_URI = "file://pointercal \
+ file://COPYING"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ fi
+}
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_DEFAULT_DEPS = "1"