aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gnuradio
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gnuradio')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index aca2f97434..e1a023f547 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -4,8 +4,6 @@ SECTION = "apps"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-PR = "r0"
-
DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \
swig-native python-numpy python-pygtk orc qt4-x11-free qwt"
@@ -23,11 +21,6 @@ RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-#do_configure_append() {
-# find ${S} -name Makefile | xargs sed -i s:'-I${STAGING_INCDIR_NATIVE'::g
-# find ${S} -name Makefile | xargs sed -i s:'-L${STAGING_LIBDIR_NATIVE'::g
-#}
-
do_configure_prepend() {
${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
@@ -39,7 +32,7 @@ do_compile_prepend() {
cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
}
-PACKAGES =+ "\
+PACKAGES += " \
${PN}-examples \
${PN}-grc \
"
@@ -53,20 +46,21 @@ FILES_${PN} += "${prefix}/etc/gnuradio/*"
FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \
${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \
+ ${datadir}/gnuradio/examples/*/.debug \
"
FILES_${PN}-examples = "${datadir}/gnuradio/examples"
-PV = "3.5.3"
+PV = "3.6.3"
FILESPATHPKG_prepend = "gnuradio-git:"
-SRCREV = "f621a52f779381cfe550b4278b83e701a747944c"
+SRCREV = "607a6fa3f80e08298ce7b3ee74ffca1590c05164"
# Make it easy to test against developer repos and branches
GIT_REPO = "gnuradio.git"
GIT_BRANCH = "master"
-SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \
+SRC_URI = "git://gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \
"
S="${WORKDIR}/git"
@@ -78,3 +72,9 @@ EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE -DENABLE_GR_QTGUI=ON -DENABLE_GR_WXGUI=O
EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
+# Only builds for machines with neon instructions. Problem is in upstream cmake.
+python () {
+ if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
+ raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
+}
+