aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/eglibc/eglibc-2.12
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/eglibc/eglibc-2.12')
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch17
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/armv4-eabi-compile-fix.patch25
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch21
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/etc/ld.so.conf0
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/generate-supported.mk11
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/ld-search-order.patch56
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch23
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch26
-rw-r--r--meta-oe/recipes-core/eglibc/eglibc-2.12/shorten-build-commands.patch81
9 files changed, 0 insertions, 260 deletions
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch
deleted file mode 100644
index 46b1584fa6..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/IO-acquire-lock-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Pending
-
-import http://sourceware.org/ml/libc-ports/2007-12/msg00000.html
-
-Index: libc/bits/stdio-lock.h
-===================================================================
---- libc.orig/bits/stdio-lock.h 2009-10-28 14:34:19.000000000 -0700
-+++ libc/bits/stdio-lock.h 2009-10-28 14:34:54.000000000 -0700
-@@ -50,6 +50,8 @@ __libc_lock_define_recursive (typedef, _
- _IO_cleanup_region_start ((void (*) (void *)) _IO_funlockfile, (_fp)); \
- _IO_flockfile (_fp)
-
-+# define _IO_acquire_lock_clear_flags2(_fp) _IO_acquire_lock (_fp)
-+
- # define _IO_release_lock(_fp) \
- _IO_funlockfile (_fp); \
- _IO_cleanup_region_end (0)
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/armv4-eabi-compile-fix.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/armv4-eabi-compile-fix.patch
deleted file mode 100644
index c2407eea09..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/armv4-eabi-compile-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Source: http://sourceware.org/bugzilla/show_bug.cgi?id=12097
-Upstream-Status: Submitted
-
-The patch should be merged into glibc-ports
-
--Khem
-Index: libc/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
-===================================================================
---- libc.orig/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
-+++ libc/ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S
-@@ -16,6 +16,8 @@
- Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
- 02111-1307 USA. */
-
-+#if defined(__thumb__)
-+
- #include <sysdep.h>
-
- /* Out-of-line syscall stub. We expect the system call number in ip
-@@ -41,3 +43,5 @@ ENTRY (__libc_do_syscall)
- pop {r7, pc}
- .fnend
- END (__libc_do_syscall)
-+
-+#endif /* __thumb__ */
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch
deleted file mode 100644
index 1e7dfa7848..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/eglibc-svn-arm-lowlevellock-include-tls.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Upstream-Status: Pending
-
-In file included from ../nptl/sysdeps/unix/sysv/linux/libc-lowlevellock.c:21:
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c: In function '__lll_lock_wait_private':
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: warning: implicit declaration of function 'THREAD_GETMEM'
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: 'THREAD_SELF' undeclared (first use in this function)
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: (Each undeclared identifier is reported only once
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: for each function it appears in.)
-../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:34: error: 'header' undeclared (first use in this function)
-make[4]: *** [/var/tmp/portage/sys-libs/glibc-2.7-r1/work/build-default-armv4l-unknown-linux-gnu-nptl/nptl/rtld-libc-lowlevellock.os] Error 1
-
---- libc/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h.orig
-+++ libc/ports/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
-@@ -25,6 +25,7 @@
- #include <atomic.h>
- #include <sysdep.h>
- #include <kernel-features.h>
-+#include <tls.h>
-
- #define FUTEX_WAIT 0
- #define FUTEX_WAKE 1
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/etc/ld.so.conf b/meta-oe/recipes-core/eglibc/eglibc-2.12/etc/ld.so.conf
deleted file mode 100644
index e69de29bb2..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/etc/ld.so.conf
+++ /dev/null
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/generate-supported.mk b/meta-oe/recipes-core/eglibc/eglibc-2.12/generate-supported.mk
deleted file mode 100644
index d2a28c2dc6..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/generate-supported.mk
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/make
-
-include $(IN)
-
-all:
- rm -f $(OUT)
- touch $(OUT)
- for locale in $(SUPPORTED-LOCALES); do \
- [ $$locale = true ] && continue; \
- echo $$locale | sed 's,/, ,' >> $(OUT); \
- done
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/ld-search-order.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/ld-search-order.patch
deleted file mode 100644
index 40ae6d37f4..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/ld-search-order.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-The default lib search path order is:
-
- 1) LD_LIBRARY_PATH
- 2) RPATH from the binary
- 3) ld.so.cache
- 4) default search paths embedded in the linker
-
-For nativesdk binaries which are being used alongside binaries on a host system, we
-need the search paths to firstly search the shipped nativesdk libs but then also
-cover the host system. For example we want the host system's libGL and this may be
-in a non-standard location like /usr/lib/mesa. The only place the location is know
-about is in the ld.so.cache of the host system.
-
-Since nativesdk has a simple structure and doesn't need to use a cache itself, we
-repurpose the cache for use as a last resort in finding host system binaries. This
-means we need to switch the order of 3 and 4 above to make this work effectively.
-
-RP 14/10/2010
-
-Index: libc/elf/dl-load.c
-===================================================================
---- libc.orig/elf/dl-load.c
-+++ libc/elf/dl-load.c
-@@ -2107,6 +2107,15 @@ _dl_map_object (struct link_map *loader,
- &loader->l_runpath_dirs, &realname, &fb, loader,
- LA_SER_RUNPATH, &found_other_class);
-
-+ /* try the default path. */
-+ if (fd == -1
-+ && ((l = loader ?: GL(dl_ns)[nsid]._ns_loaded) == NULL
-+ || __builtin_expect (!(l->l_flags_1 & DF_1_NODEFLIB), 1))
-+ && rtld_search_dirs.dirs != (void *) -1)
-+ fd = open_path (name, namelen, mode & __RTLD_SECURE, &rtld_search_dirs,
-+ &realname, &fb, l, LA_SER_DEFAULT, &found_other_class);
-+
-+ /* Finally try ld.so.cache */
- if (fd == -1
- && (__builtin_expect (! (mode & __RTLD_SECURE), 1)
- || ! INTUSE(__libc_enable_secure)))
-@@ -2169,14 +2178,6 @@ _dl_map_object (struct link_map *loader,
- }
- }
-
-- /* Finally, try the default path. */
-- if (fd == -1
-- && ((l = loader ?: GL(dl_ns)[nsid]._ns_loaded) == NULL
-- || __builtin_expect (!(l->l_flags_1 & DF_1_NODEFLIB), 1))
-- && rtld_search_dirs.dirs != (void *) -1)
-- fd = open_path (name, namelen, mode & __RTLD_SECURE, &rtld_search_dirs,
-- &realname, &fb, l, LA_SER_DEFAULT, &found_other_class);
--
- /* Add another newline when we are tracing the library loading. */
- if (__builtin_expect (GLRO_dl_debug_mask & DL_DEBUG_LIBS, 0))
- _dl_debug_printf ("\n");
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch
deleted file mode 100644
index 186c705e56..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/mips-rld-map-check.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Upstream-Status: Pending
-
-On mips target, binutils currently sets DT_MIPS_RLD_MAP to 0 in dynamic
-section if a --version-script sets _RLD_MAP to local. This is apparently
-a binutils bug, but libc shouldn't segfault in this case.
-
-see also: http://sourceware.org/bugilla/show_bug.cgi?id=11615
-
-9/19/2010 - added by Qing He <qing.he@intel.com>
----
-diff -ru glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h glibc-2.10.1/ports/sysdeps/mips/dl-machine.h
---- glibc-2.10.1.orig/ports/sysdeps/mips/dl-machine.h 2009-05-16 16:36:20.000000000 +0800
-+++ glibc-2.10.1/ports/sysdeps/mips/dl-machine.h 2010-09-19 09:11:53.000000000 +0800
-@@ -70,7 +70,8 @@
- /* If there is a DT_MIPS_RLD_MAP entry in the dynamic section, fill it in
- with the run-time address of the r_debug structure */
- #define ELF_MACHINE_DEBUG_SETUP(l,r) \
--do { if ((l)->l_info[DT_MIPS (RLD_MAP)]) \
-+do { if ((l)->l_info[DT_MIPS (RLD_MAP)] && \
-+ (l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) \
- *(ElfW(Addr) *)((l)->l_info[DT_MIPS (RLD_MAP)]->d_un.d_ptr) = \
- (ElfW(Addr)) (r); \
- } while (0)
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch
deleted file mode 100644
index 70d3aed707..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/ppc-enable-603e-cpu.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-We now pass --with-cpu option to eglibc this ends up with configure errors if we do
-not pass a cpu which eglibc has support for in sysdeps
-
-| checking sysdep dirs... configure: error: The 603e subspecies of powerpc is not supported.
-| + bbfatal 'oe_runconf failed'
-| + echo 'ERROR: oe_runconf failed'
-
-We fix this by adding the 603e sub directories with Implies to generic
-powerpc to overcome this error
-
-Upstream-Status: Inappropriate [OE config related]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: libc/ports/sysdeps/powerpc/powerpc32/603e/fpu/Implies
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ libc/ports/sysdeps/powerpc/powerpc32/603e/fpu/Implies 2011-12-05 22:18:14.151326027 -0800
-@@ -0,0 +1 @@
-+powerpc/powerpc32/fpu
-Index: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/fpu/Implies
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/603e/fpu/Implies 2011-12-05 22:16:11.751326040 -0800
-@@ -0,0 +1 @@
-+powerpc/powerpc32/603e/fpu
diff --git a/meta-oe/recipes-core/eglibc/eglibc-2.12/shorten-build-commands.patch b/meta-oe/recipes-core/eglibc/eglibc-2.12/shorten-build-commands.patch
deleted file mode 100644
index 90e644ec3c..0000000000
--- a/meta-oe/recipes-core/eglibc/eglibc-2.12/shorten-build-commands.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-Upstream-Status: Pending
-
-Source: http://sourceware.org/ml/libc-alpha/2010-03/msg00064.html
-
-This patch scratches an itch. Each individual gcc command in the
-glibc build is over 1K, which means it takes up a good chunk of my
-terminal. Most of that is include paths. Any version of GCC new
-enough to build glibc supports response files, which were added in
-2005. So use a response file for the static list of include paths.
-Now the build commands are a lot shorter, and easier to use when
-developing glibc.
-
-Tested on x86_64-linux-gnu. Please apply if acceptable.
-
---
-Daniel Jacobowitz
-CodeSourcery
-
-2010-03-30 Daniel Jacobowitz <dan@codesourcery.com>
-
- * Makeconfig (+common-includes): Define.
- (+includes): Use @$(common-objpfx)includes.
- * Makefile (postclean): Remove includes and includes.mk.
- * Makerules ($(common-objpfx)includes.mk): Include and create
- includes.mk. Create includes.
-
-Index: libc/Makeconfig
-===================================================================
---- libc.orig/Makeconfig 2009-10-13 22:55:12.000000000 -0700
-+++ libc/Makeconfig 2010-03-31 16:02:37.120489733 -0700
-@@ -678,9 +678,10 @@ endif # $(+cflags) == ""
- # library source directory, in the include directory, and in the
- # current directory.
- +sysdep-includes = $(addprefix -I,$(+sysdep_dirs))
-++common-includes = $(+sysdep-includes) $(includes) $(sysincludes)
- +includes = -I$(..)include $(if $(subdir),$(objpfx:%/=-I%)) \
-- $(+sysdep-includes) $(includes) \
-- $(patsubst %/,-I%,$(..)) $(libio-include) -I. $(sysincludes)
-+ @$(common-objpfx)includes \
-+ $(patsubst %/,-I%,$(..)) $(libio-include) -I.
-
- # Since libio has several internal header files, we use a -I instead
- # of many little headers in the include directory.
-Index: libc/Makefile
-===================================================================
---- libc.orig/Makefile 2009-12-09 12:06:28.000000000 -0800
-+++ libc/Makefile 2010-03-31 16:02:37.132481508 -0700
-@@ -247,7 +247,7 @@ parent-mostlyclean: common-mostlyclean #
- parent-clean: parent-mostlyclean common-clean
-
- postclean = $(addprefix $(common-objpfx),$(postclean-generated)) \
-- $(addprefix $(objpfx),sysd-dirs sysd-rules) \
-+ $(addprefix $(objpfx),sysd-dirs sysd-rules includes includes.mk) \
- $(addprefix $(objpfx),sysd-sorted soversions.mk soversions.i)
-
- clean: parent-clean
-Index: libc/Makerules
-===================================================================
---- libc.orig/Makerules 2009-12-09 12:06:28.000000000 -0800
-+++ libc/Makerules 2010-03-31 16:02:37.140481645 -0700
-@@ -254,6 +254,20 @@ ifndef sysd-rules-done
- no_deps=t
- endif
-
-+-include $(common-objpfx)includes.mk
-+ifneq ($(+common-includes),$(saved-includes))
-+# Recreate includes.mk (and includes).
-+includes-force = FORCE
-+FORCE:
-+endif
-+$(common-objpfx)includes.mk: $(includes-force)
-+ -@rm -f $@T $(common-objpfx)includesT
-+ for inc in $(+common-includes); do echo "$$inc"; done \
-+ > $(common-objpfx)includesT
-+ mv -f $(common-objpfx)includesT $(common-objpfx)includes
-+ echo 'saved-includes := $(+common-includes)' > $@T
-+ mv -f $@T $@
-+
- define o-iterator-doit
- $(objpfx)%$o: %.S $(before-compile); $$(compile-command.S)
- endef