aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch b/meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch
new file mode 100644
index 0000000000..1bfc3bdb18
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd-v189/systemd-pam-configure-check-uclibc.patch
@@ -0,0 +1,26 @@
+--- systemd-185.orig/configure.ac 2012-06-04 14:15:16.000000000 -0400
++++ systemd-pam-185/configure.ac 2012-06-21 22:57:10.000000000 -0400
+@@ -63,6 +63,23 @@
+
+ AC_PATH_PROG([M4], [m4])
+
++# check for few functions not implemented in uClibc
++
++AC_CHECK_FUNCS_ONCE(mkostemp execvpe posix_fallocate)
++
++# check for %ms format support - assume always no if cross compiling
++
++AC_MSG_CHECKING([whether %ms format is supported by *scanf])
++
++AC_RUN_IFELSE(
++ [AC_LANG_PROGRAM([[ include <stdio.h> ]],
++ [[ char *buf1, *buf2, *buf3, str="1 2.3 abcde" ;
++ int rc = sscanf(str, "%ms %ms %ms", &buf1, &buf2, &buf3) ;
++ return (rc==3)?0:1;]])],
++ [AC_DEFINE([HAVE_MSFORMAT], [1], [Define if %ms format is supported by *scanf.])],
++ [AC_MSG_RESULT([no])],
++ [AC_MSG_RESULT([no])])
++
+ # gtkdocize greps for '^GTK_DOC_CHECK', so it needs to be on its own line
+ m4_ifdef([GTK_DOC_CHECK], [
+ GTK_DOC_CHECK([1.18],[--flavour no-tmpl])