aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 7b0771a00a..228e0e4b3c 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -108,7 +108,6 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
# TODO:
# u-a for runlevel and telinit
-# u-a prerm
pkg_postinst_systemd () {
update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
@@ -117,3 +116,11 @@ update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/syste
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
}
+
+pkg_prerm_systemd () {
+update-alternatives --remove init ${base_bindir}/systemd
+update-alternatives --remove halt ${base_bindir}/systemctl
+update-alternatives --remove reboot ${base_bindir}/systemctl
+update-alternatives --remove shutdown ${base_bindir}/systemctl
+update-alternatives --remove poweroff ${base_bindir}/systemctl
+}