aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules.bb36
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/automount.rules19
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/autonet.rules19
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/local.rules21
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/mount.blacklist3
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/mount.sh64
-rw-r--r--meta-oe/recipes-core/udev/udev-extra-rules/network.sh58
7 files changed, 0 insertions, 220 deletions
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules.bb b/meta-oe/recipes-core/udev/udev-extra-rules.bb
deleted file mode 100644
index 7f9ca85f5f..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Extra udev rules"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-inherit allarch
-
-PR = "r4"
-
-SRC_URI = " \
- file://automount.rules \
- file://mount.sh \
- file://mount.blacklist \
- file://autonet.rules \
- file://network.sh \
- file://local.rules \
-"
-
-
-do_install() {
- install -d ${D}${sysconfdir}/udev/rules.d
-
- install -m 0644 ${WORKDIR}/automount.rules ${D}${sysconfdir}/udev/rules.d/automount.rules
- install -m 0644 ${WORKDIR}/autonet.rules ${D}${sysconfdir}/udev/rules.d/autonet.rules
- install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
-
- install -m 0644 ${WORKDIR}/mount.blacklist ${D}${sysconfdir}/udev/
-
- install -d ${D}${sysconfdir}/udev/scripts/
-
- install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
- install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
-}
-
-FILES_${PN} = "${sysconfdir}/udev"
-RDEPENDS_${PN} = "udev"
-CONFFILES_${PN} = "${sysconfdir}/udev/mount.blacklist"
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/automount.rules b/meta-oe/recipes-core/udev/udev-extra-rules/automount.rules
deleted file mode 100644
index 7e844c31bd..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/automount.rules
+++ /dev/null
@@ -1,19 +0,0 @@
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-# For example, 'sda3' has a "kernel number" of '3'
-# %e the smallest number for that name which does not matches an existing node
-# %k the kernel name for the device
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute
-# %% the '%' char itself
-#
-
-# Media automounting
-SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
-SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
-
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/autonet.rules b/meta-oe/recipes-core/udev/udev-extra-rules/autonet.rules
deleted file mode 100644
index 19676aa13b..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/autonet.rules
+++ /dev/null
@@ -1,19 +0,0 @@
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-# For example, 'sda3' has a "kernel number" of '3'
-# %e the smallest number for that name which does not matches an existing node
-# %k the kernel name for the device
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute
-# %% the '%' char itself
-#
-
-# Handle network interface setup
-SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
-SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
-
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/local.rules b/meta-oe/recipes-core/udev/udev-extra-rules/local.rules
deleted file mode 100644
index 4eaa8ca9b0..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/local.rules
+++ /dev/null
@@ -1,21 +0,0 @@
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-# For example, 'sda3' has a "kernel number" of '3'
-# %e the smallest number for that name which does not matches an existing node
-# %k the kernel name for the device
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute
-# %% the '%' char itself
-#
-
-# The first rtc device is symlinked to /dev/rtc
-KERNEL=="rtc0", SYMLINK+="rtc"
-
-#The first framebuffer is symlinked to /dev/fb
-KERNEL=="fb0", SYMLINK+="fb"
-
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/mount.blacklist b/meta-oe/recipes-core/udev/udev-extra-rules/mount.blacklist
deleted file mode 100644
index d3ebb17176..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/mount.blacklist
+++ /dev/null
@@ -1,3 +0,0 @@
-/dev/loop
-/dev/ram
-/dev/mtdblock
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/mount.sh b/meta-oe/recipes-core/udev/udev-extra-rules/mount.sh
deleted file mode 100644
index 67c2b4b507..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/mount.sh
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/bin/sh
-#
-# Called from udev
-# Attemp to mount any added block devices
-# and remove any removed devices
-#
-
-MOUNT="/bin/mount"
-PMOUNT="/usr/bin/pmount"
-UMOUNT="/bin/umount"
-name="`basename "$DEVNAME"`"
-
-for line in `grep -v ^# /etc/udev/mount.blacklist`
-do
- if ( echo "$DEVNAME" | grep -q "$line" )
- then
- logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
- exit 0
- fi
-done
-
-automount() {
- ! test -d "/media/$name" && mkdir -p "/media/$name"
-
- if ! $MOUNT -t auto -o async,relatime $DEVNAME "/media/$name"
- then
- #logger "mount.sh/automount" "$MOUNT -t auto $DEVNAME \"/media/$name\" failed!"
- rm_dir "/media/$name"
- else
- logger "mount.sh/automount" "Auto-mount of [/media/$name] successful"
- touch "/tmp/.automount-$name"
- fi
-}
-
-rm_dir() {
- # We do not want to rm -r populated directories
- if test "`find "$1" | wc -l | tr -d " "`" -lt 2 -a -d "$1"
- then
- ! test -z "$1" && rm -r "$1"
- else
- logger "mount.sh/automount" "Not removing non-empty directory [$1]"
- fi
-}
-
-if [ "$ACTION" = "add" ] && [ -n "$DEVNAME" ]; then
- if [ -x "$PMOUNT" ]; then
- $PMOUNT $DEVNAME 2> /dev/null
- elif [ -x $MOUNT ]; then
- $MOUNT $DEVNAME 2> /dev/null
- fi
-
- # Avoid remounting devices (e.g: rootfs)
- awk '{print $1}' /proc/mounts | grep -q "^$DEVNAME$" || automount
-fi
-
-if [ "$ACTION" = "remove" ] && [ -x "$UMOUNT" ] && [ -n "$DEVNAME" ]; then
- for mnt in `grep "$DEVNAME" /proc/mounts | cut -f 2 -d " " `
- do
- $UMOUNT -l $mnt
- done
-
- # Remove empty directories from auto-mounter
- test -e "/tmp/.automount-$name" && rm_dir "/media/$name"
-fi
diff --git a/meta-oe/recipes-core/udev/udev-extra-rules/network.sh b/meta-oe/recipes-core/udev/udev-extra-rules/network.sh
deleted file mode 100644
index 182c26d86a..0000000000
--- a/meta-oe/recipes-core/udev/udev-extra-rules/network.sh
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh
-
-# udevd does clearenv(). Export shell PATH to children.
-export PATH
-
-# Do not run when pcmcia-cs is installed
-test -x /sbin/cardctl && exit 0
-
-# We get two "add" events for hostap cards due to wifi0
-echo "$INTERFACE" | grep -q wifi && exit 0
-
-
-# Check if /etc/init.d/network has been run yet to see if we are
-# called by starting /etc/rcS.d/S03udev and not by hotplugging a device
-#
-# At this stage, network interfaces should not be brought up
-# automatically because:
-# a) /etc/init.d/network has not been run yet (security issue)
-# b) /var has not been populated yet so /etc/resolv,conf points to
-# oblivion, making the network unusable
-#
-
-spoofp="`grep ^spoofprotect /etc/network/options`"
-if test -z "$spoofp"
-then
- # This is the default from /etc/init.d/network
- spoofp_val=yes
-else
- spoofp_val=${spoofp#spoofprotect=}
-fi
-
-test "$spoofp_val" = yes && spoofp_val=1 || spoofp_val=0
-
-# I think it is safe to assume that "lo" will always be there ;)
-if test "`cat /proc/sys/net/ipv4/conf/lo/rp_filter`" != "$spoofp_val" -a -n "$spoofp_val"
-then
- echo "$INTERFACE" >> /dev/udev_network_queue
- exit 0
-fi
-
-#
-# Code taken from pcmcia-cs:/etc/pcmcia/network
-#
-
-# if this interface has an entry in /etc/network/interfaces, let ifupdown
-# handle it
-if grep -q "iface \+$INTERFACE" /etc/network/interfaces; then
- case $ACTION in
- add)
- ifconfig | grep -q "^$INTERFACE" || ifup $INTERFACE
- ;;
- remove)
- ifdown $INTERFACE
- ;;
- esac
-
- exit 0
-fi