aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch34
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch37
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch25
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch29
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker_git.bb13
5 files changed, 74 insertions, 64 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch
deleted file mode 100644
index f10c49e7c3..0000000000
--- a/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From a92fd7da3a262e21c0970a3908eb0b4502819a01 Mon Sep 17 00:00:00 2001
-From: Yang Lyu <yangl@axis.com>
-Date: Fri, 23 Feb 2018 16:31:49 +0100
-Subject: [PATCH] Comment rst2man related stuff
-
----
- meson.build | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 56d38e4..3c3b109 100644
---- a/meson.build
-+++ b/meson.build
-@@ -15,7 +15,7 @@ add_project_arguments('-DBINDIR="' + join_paths(get_option('prefix'), get_option
- cc = meson.get_compiler('c')
- conf = configuration_data()
- mod_pkgconfig = import('pkgconfig')
--prog_rst2man = find_program('rst2man', 'rst2man.py')
-+#prog_rst2man = find_program('rst2man', 'rst2man.py')
-
- sub_cdvar = subproject('c-dvar', version: '>=1')
- sub_clist = subproject('c-list', version: '>=3')
-@@ -56,7 +56,7 @@ endif
-
- conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))
-
--subdir('docs')
-+#subdir('docs')
- subdir('src')
-
- if use_launcher
---
-2.1.4
-
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch
new file mode 100644
index 0000000000..8b8be074fe
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch
@@ -0,0 +1,37 @@
+From 99657fcbba288a843dc9e411bdfd3934b2074db5 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 28 Jun 2018 07:11:58 -0700
+Subject: [PATCH] Include sys/wait.h for WEXITED definition
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ src/launch/main.c | 1 +
+ test/dbus/util-broker.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/launch/main.c b/src/launch/main.c
+index f335d6b..6475ae6 100644
+--- a/src/launch/main.c
++++ b/src/launch/main.c
+@@ -16,6 +16,7 @@
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/un.h>
++#include <sys/wait.h>
+ #include <systemd/sd-bus.h>
+ #include <systemd/sd-daemon.h>
+ #include <systemd/sd-event.h>
+diff --git a/test/dbus/util-broker.c b/test/dbus/util-broker.c
+index d9367ae..3bd021b 100644
+--- a/test/dbus/util-broker.c
++++ b/test/dbus/util-broker.c
+@@ -11,6 +11,7 @@
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/un.h>
++#include <sys/wait.h>
+ #include <systemd/sd-bus.h>
+ #include <systemd/sd-event.h>
+ #include "dbus/protocol.h"
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch
deleted file mode 100644
index 4909dea125..0000000000
--- a/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4b79f603b948709906c108796087de7b5643f61a Mon Sep 17 00:00:00 2001
-From: Yang Lyu <yangl@axis.com>
-Date: Mon, 26 Feb 2018 12:48:34 +0100
-Subject: [PATCH] Correct including directory for conf
-
----
- src/launch/config.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/launch/config.c b/src/launch/config.c
-index 6a68699..579471b 100644
---- a/src/launch/config.c
-+++ b/src/launch/config.c
-@@ -1022,7 +1022,7 @@ static void config_parser_end_fn(void *userdata, const XML_Char *name) {
- state->file,
- state->current->include.selinux_root_relative ?
- bus_selinux_policy_root() :
-- state->file->path,
-+ NULL,
- state->current->cdata);
- if (r) {
- state->error = error_trace(r);
---
-2.1.4
-
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch
new file mode 100644
index 0000000000..bebd2145f2
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch
@@ -0,0 +1,29 @@
+From 95a5541f8b75f7896ee6e5e71edd61838cab3c8b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 28 Jun 2018 07:16:34 -0700
+Subject: [PATCH] Use getenv instead of secure_getenv on musl
+
+musl doesnt implement secure version
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ src/launch/main.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/launch/main.c b/src/launch/main.c
+index 6475ae6..6468d84 100644
+--- a/src/launch/main.c
++++ b/src/launch/main.c
+@@ -30,6 +30,10 @@
+ #include "util/log.h"
+ #include "util/misc.h"
+
++#ifndef __GLIBC__
++#define secure_getenv getenv
++#endif
++
+ typedef struct Manager Manager;
+ typedef struct Service Service;
+
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
index b62bccf2c9..4a025cfeb1 100644
--- a/meta-oe/recipes-core/dbus/dbus-broker_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
@@ -8,17 +8,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
DEPENDS = "dbus glib-2.0 expat"
-PV = "9+git${SRCPV}"
-SRCREV = "ccd06b284892182af569e69046262331150e3536"
+PV = "13+git${SRCPV}"
+SRCREV = "1165025e26c3b46160402841dadf08d3d42f5cbb"
-SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git"
-SRC_URI += "file://0001-Comment-rst2man-related-stuff.patch"
-SRC_URI += "file://0002-Correct-including-directory-for-conf.patch"
+SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git \
+ file://0001-Include-sys-wait.h-for-WEXITED-definition.patch \
+ file://0002-Use-getenv-instead-of-secure_getenv-on-musl.patch \
+ "
S = "${WORKDIR}/git"
inherit meson pkgconfig systemd distro_features_check
+EXTRA_OEMESON += "-Ddocs=false"
+
REQUIRED_DISTRO_FEATURES = "systemd"
SYSTEMD_SERVICE_${PN} = "${BPN}.service"